about summary refs log tree commit diff
path: root/nixos/modules/services/x11/display-managers/sddm.nix
diff options
context:
space:
mode:
authorTor Hedin Brønner <torhedinbronner@gmail.com>2018-07-24 16:52:49 +0200
committerJan Tojnar <jtojnar@gmail.com>2018-08-01 19:14:32 +0200
commit9fad9fb8698fd13f52004b73788ba462906b6c85 (patch)
tree75d35e6459cb3580b3bef874b82eb598499a189e /nixos/modules/services/x11/display-managers/sddm.nix
parentadbe4e1c68e6e8c8a37326cb41f8a03c1c7697e1 (diff)
downloadnixlib-9fad9fb8698fd13f52004b73788ba462906b6c85.tar
nixlib-9fad9fb8698fd13f52004b73788ba462906b6c85.tar.gz
nixlib-9fad9fb8698fd13f52004b73788ba462906b6c85.tar.bz2
nixlib-9fad9fb8698fd13f52004b73788ba462906b6c85.tar.lz
nixlib-9fad9fb8698fd13f52004b73788ba462906b6c85.tar.xz
nixlib-9fad9fb8698fd13f52004b73788ba462906b6c85.tar.zst
nixlib-9fad9fb8698fd13f52004b73788ba462906b6c85.zip
nixos/displayManager: Create a common environment wrapper for all dms
This makes it easier to support a wider variety of .desktop session files. In
particular this makes it possible to use both the «legacy» sessions and upstream
session files.

We separate `xsession` into two parts, `xsessionWrapper` and `xsession`.
`xsessionWrapper` sets up the correct environment and then lauches the session's
Exec command (from the .desktop file), falling back to launching the default
window/desktopManager through the `xsession` script (required by at least some
nixos tests).

`xsession` then _only_ handles launching desktop-managers/window-managers defined
through `services.xserver.desktopManager.session`.
Diffstat (limited to 'nixos/modules/services/x11/display-managers/sddm.nix')
-rw-r--r--nixos/modules/services/x11/display-managers/sddm.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/x11/display-managers/sddm.nix b/nixos/modules/services/x11/display-managers/sddm.nix
index c6a150e31707..1b3478039327 100644
--- a/nixos/modules/services/x11/display-managers/sddm.nix
+++ b/nixos/modules/services/x11/display-managers/sddm.nix
@@ -49,7 +49,7 @@ let
     MinimumVT=${toString (if xcfg.tty != null then xcfg.tty else 7)}
     ServerPath=${xserverWrapper}
     XephyrPath=${pkgs.xorg.xorgserver.out}/bin/Xephyr
-    SessionCommand=${dmcfg.session.script}
+    SessionCommand=${dmcfg.session.wrapper}
     SessionDir=${dmcfg.session.desktops}/share/xsessions
     XauthPath=${pkgs.xorg.xauth}/bin/xauth
     DisplayCommand=${Xsetup}