about summary refs log tree commit diff
path: root/nixos/modules/services/x11/display-managers/gdm.nix
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2020-04-05 16:30:17 +0200
committerJan Tojnar <jtojnar@gmail.com>2020-04-05 16:40:30 +0200
commitf74f2f354866c828248a419ef9a2cbddc793b7f9 (patch)
tree82e73de7da78b276debb3e393f92a1bd685417fb /nixos/modules/services/x11/display-managers/gdm.nix
parent52f76b890722878b068c95e562ed7c4c97752885 (diff)
downloadnixlib-f74f2f354866c828248a419ef9a2cbddc793b7f9.tar
nixlib-f74f2f354866c828248a419ef9a2cbddc793b7f9.tar.gz
nixlib-f74f2f354866c828248a419ef9a2cbddc793b7f9.tar.bz2
nixlib-f74f2f354866c828248a419ef9a2cbddc793b7f9.tar.lz
nixlib-f74f2f354866c828248a419ef9a2cbddc793b7f9.tar.xz
nixlib-f74f2f354866c828248a419ef9a2cbddc793b7f9.tar.zst
nixlib-f74f2f354866c828248a419ef9a2cbddc793b7f9.zip
nixos/gdm: fix startup
In https://github.com/NixOS/nixpkgs/commit/7f838b4ddeadffbbe5863a6ca27ad776064a2f4a, we dropped systemd-udev-settle.service from display-manager.service's wants.
Unfortunately, we are doing something wrong since without it both Xorg and Wayland fail to start:

	Failed to open gpu '/dev/dri/card0': GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Operation not permitted

Until we sort this out, let's add systemd-udev-settle.service to GDM to unblock the channels.
Diffstat (limited to 'nixos/modules/services/x11/display-managers/gdm.nix')
-rw-r--r--nixos/modules/services/x11/display-managers/gdm.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/nixos/modules/services/x11/display-managers/gdm.nix b/nixos/modules/services/x11/display-managers/gdm.nix
index 9b4cca56d7f0..d7bef68e5bcb 100644
--- a/nixos/modules/services/x11/display-managers/gdm.nix
+++ b/nixos/modules/services/x11/display-managers/gdm.nix
@@ -188,6 +188,9 @@ in
       "systemd-machined.service"
       # setSessionScript wants AccountsService
       "accounts-daemon.service"
+      # Failed to open gpu '/dev/dri/card0': GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Operation not permitted
+      # https://github.com/NixOS/nixpkgs/pull/25311#issuecomment-609417621
+      "systemd-udev-settle.service"
     ];
 
     systemd.services.display-manager.after = [
@@ -197,6 +200,7 @@ in
       "getty@tty${gdm.initialVT}.service"
       "plymouth-quit.service"
       "plymouth-start.service"
+      "systemd-udev-settle.service"
     ];
     systemd.services.display-manager.conflicts = [
        "getty@tty${gdm.initialVT}.service"