about summary refs log tree commit diff
path: root/nixos/modules/services/x11/display-managers/default.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2014-08-27 23:41:15 +0200
committeraszlig <aszlig@redmoonstudios.org>2014-08-27 23:41:15 +0200
commit8a56a55bb442cbf2e2126d40df55e67b9aea0361 (patch)
tree916948eff016c868746d3a31b9e6f6120d33e449 /nixos/modules/services/x11/display-managers/default.nix
parent9667a4067c7e3f02a6a0fe8f1f3344c1cb1d7ef7 (diff)
downloadnixlib-8a56a55bb442cbf2e2126d40df55e67b9aea0361.tar
nixlib-8a56a55bb442cbf2e2126d40df55e67b9aea0361.tar.gz
nixlib-8a56a55bb442cbf2e2126d40df55e67b9aea0361.tar.bz2
nixlib-8a56a55bb442cbf2e2126d40df55e67b9aea0361.tar.lz
nixlib-8a56a55bb442cbf2e2126d40df55e67b9aea0361.tar.xz
nixlib-8a56a55bb442cbf2e2126d40df55e67b9aea0361.tar.zst
nixlib-8a56a55bb442cbf2e2126d40df55e67b9aea0361.zip
nixos/manual: Use literalExample when feasible.
Should bring most of the examples into a better consistency regarding
syntactic representation in the manual.

Thanks to @devhell for reporting.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/modules/services/x11/display-managers/default.nix')
-rw-r--r--nixos/modules/services/x11/display-managers/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/nixos/modules/services/x11/display-managers/default.nix b/nixos/modules/services/x11/display-managers/default.nix
index 3bf18bd58c84..6e61576f501f 100644
--- a/nixos/modules/services/x11/display-managers/default.nix
+++ b/nixos/modules/services/x11/display-managers/default.nix
@@ -251,14 +251,16 @@ in
 
         execCmd = mkOption {
           type = types.str;
-          example = "${pkgs.slim}/bin/slim";
+          example = literalExample ''
+            "''${pkgs.slim}/bin/slim"
+          '';
           description = "Command to start the display manager.";
         };
 
         environment = mkOption {
           type = types.attrsOf types.unspecified;
           default = {};
-          example = { SLIM_CFGFILE = /etc/slim.conf; };
+          example = { SLIM_CFGFILE = "/etc/slim.conf"; };
           description = "Additional environment variables needed by the display manager.";
         };