about summary refs log tree commit diff
path: root/nixos/modules/services/x11/display-managers/default.nix
diff options
context:
space:
mode:
authorPeter Hoeg <peter@speartail.com>2016-09-20 15:21:08 +0800
committerDomen Kožar <domen@dev.si>2016-09-30 13:14:53 +0200
commit639e5401ff51d4c0075b5ceffcbdbfec64c67db3 (patch)
tree7cb5566c83ce58d4084401185421b790a3d36298 /nixos/modules/services/x11/display-managers/default.nix
parent2a53b06e0661758ff2c206aa7e41764f1081c9b3 (diff)
downloadnixlib-639e5401ff51d4c0075b5ceffcbdbfec64c67db3.tar
nixlib-639e5401ff51d4c0075b5ceffcbdbfec64c67db3.tar.gz
nixlib-639e5401ff51d4c0075b5ceffcbdbfec64c67db3.tar.bz2
nixlib-639e5401ff51d4c0075b5ceffcbdbfec64c67db3.tar.lz
nixlib-639e5401ff51d4c0075b5ceffcbdbfec64c67db3.tar.xz
nixlib-639e5401ff51d4c0075b5ceffcbdbfec64c67db3.tar.zst
nixlib-639e5401ff51d4c0075b5ceffcbdbfec64c67db3.zip
dbus: add socket activation but do not enable it
The following changes are included:

1) install user unit files from upstream dbus
2) use absolute paths to config for --system and --session instances
3) make socket activation of user units configurable

There has been a number of PRs to address this, so this one does the
bare minimum, which is to make the functionality available and
configurable but defaults to off.

Related PRs:
 - #18382
 - #18222

(cherry picked from commit f7215c9b5b47dfb0a6dbe87ff33d7730729a32e5)
Signed-off-by: Domen Kožar <domen@dev.si>
Diffstat (limited to 'nixos/modules/services/x11/display-managers/default.nix')
-rw-r--r--nixos/modules/services/x11/display-managers/default.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/nixos/modules/services/x11/display-managers/default.nix b/nixos/modules/services/x11/display-managers/default.nix
index 75d80609f73f..ce82af4ca68c 100644
--- a/nixos/modules/services/x11/display-managers/default.nix
+++ b/nixos/modules/services/x11/display-managers/default.nix
@@ -134,13 +134,8 @@ let
         (*) echo "$0: Desktop manager '$desktopManager' not found.";;
       esac
 
-      # FIXME: gdbus should not be in glib.dev!
-      ${optionalString (cfg.startDbusSession && cfg.updateDbusEnvironment) ''
-        ${pkgs.glib.dev}/bin/gdbus call --session \
-          --dest org.freedesktop.DBus --object-path /org/freedesktop/DBus \
-          --method org.freedesktop.DBus.UpdateActivationEnvironment \
-          "{$(env | ${pkgs.gnused}/bin/sed "s/'/\\\\'/g; s/\([^=]*\)=\(.*\)/'\1':'\2'/" \
-                  | ${pkgs.coreutils}/bin/paste -sd,)}"
+      ${optionalString cfg.updateDbusEnvironment ''
+        ${lib.getBin pkgs.dbus}/bin/dbus-update-activation-environment --systemd --all
       ''}
 
       test -n "$waitPID" && wait "$waitPID"