about summary refs log tree commit diff
path: root/nixos/modules/services/x11/display-managers/default.nix
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-03-09 18:04:40 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-03-09 18:10:31 -0700
commit4940e643ccdbaa224cd06a588bd5608e03c29dcf (patch)
tree57c8e82b0c6a5ca13bdd0fc85da5d32aaf4da386 /nixos/modules/services/x11/display-managers/default.nix
parent66bfdf6eb00c8def644fcd534e979db470a33b55 (diff)
downloadnixlib-4940e643ccdbaa224cd06a588bd5608e03c29dcf.tar
nixlib-4940e643ccdbaa224cd06a588bd5608e03c29dcf.tar.gz
nixlib-4940e643ccdbaa224cd06a588bd5608e03c29dcf.tar.bz2
nixlib-4940e643ccdbaa224cd06a588bd5608e03c29dcf.tar.lz
nixlib-4940e643ccdbaa224cd06a588bd5608e03c29dcf.tar.xz
nixlib-4940e643ccdbaa224cd06a588bd5608e03c29dcf.tar.zst
nixlib-4940e643ccdbaa224cd06a588bd5608e03c29dcf.zip
nixos/display-manager: Support configurable hidden users
Diffstat (limited to 'nixos/modules/services/x11/display-managers/default.nix')
-rw-r--r--nixos/modules/services/x11/display-managers/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/nixos/modules/services/x11/display-managers/default.nix b/nixos/modules/services/x11/display-managers/default.nix
index ea45dabd1257..c5012dbb5e30 100644
--- a/nixos/modules/services/x11/display-managers/default.nix
+++ b/nixos/modules/services/x11/display-managers/default.nix
@@ -208,6 +208,14 @@ in
         description = "Shell commands executed just before the window or desktop manager is started.";
       };
 
+      hiddenUsers = mkOption {
+        type = types.listOf types.str;
+        default = [ "nobody" ];
+        description = ''
+          A list of users which will not be shown in the display manager.
+        '';
+      };
+
       desktopManagerHandlesLidAndPower = mkOption {
         type = types.bool;
         default = true;