about summary refs log tree commit diff
path: root/nixos/modules/services/web-servers/nginx/vhost-options.nix
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2023-10-23 12:02:04 +0000
committerGitHub <noreply@github.com>2023-10-23 12:02:04 +0000
commit2c2c0379b759c234413de63478847266cdc8ed93 (patch)
tree92ebd45d1cd2a17d5fb63ff5c6c006a4d8f25f7e /nixos/modules/services/web-servers/nginx/vhost-options.nix
parent1026189bd67abfd6f7def1c697988217caafbc5c (diff)
parenta3b463e8874fe9182e758919eeb18bb44070097c (diff)
downloadnixlib-2c2c0379b759c234413de63478847266cdc8ed93.tar
nixlib-2c2c0379b759c234413de63478847266cdc8ed93.tar.gz
nixlib-2c2c0379b759c234413de63478847266cdc8ed93.tar.bz2
nixlib-2c2c0379b759c234413de63478847266cdc8ed93.tar.lz
nixlib-2c2c0379b759c234413de63478847266cdc8ed93.tar.xz
nixlib-2c2c0379b759c234413de63478847266cdc8ed93.tar.zst
nixlib-2c2c0379b759c234413de63478847266cdc8ed93.zip
Merge staging-next into staging
Diffstat (limited to 'nixos/modules/services/web-servers/nginx/vhost-options.nix')
-rw-r--r--nixos/modules/services/web-servers/nginx/vhost-options.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/nixos/modules/services/web-servers/nginx/vhost-options.nix b/nixos/modules/services/web-servers/nginx/vhost-options.nix
index c82f02ecefec..9db4c8e23025 100644
--- a/nixos/modules/services/web-servers/nginx/vhost-options.nix
+++ b/nixos/modules/services/web-servers/nginx/vhost-options.nix
@@ -35,7 +35,10 @@ with lib;
           };
           port = mkOption {
             type = types.nullOr port;
-            description = lib.mdDoc "Port number.";
+            description = lib.mdDoc ''
+              Port number to listen on.
+              If unset and the listen address is not a socket then nginx defaults to 80.
+            '';
             default = null;
           };
           ssl = mkOption {