about summary refs log tree commit diff
path: root/nixos/modules/services/web-servers/nginx/default.nix
diff options
context:
space:
mode:
authorIzorkin <izorkin@elven.pw>2023-03-25 19:36:42 +0300
committerIzorkin <izorkin@elven.pw>2023-04-01 13:56:26 +0300
commit427ae14373ecc86fac5037f6c71ff4ccedd9a421 (patch)
tree181b186a33d668cc9342a4b065766dee5e4516a7 /nixos/modules/services/web-servers/nginx/default.nix
parent9448487d9f7056253ecadfdab7d7bdc638191de2 (diff)
downloadnixlib-427ae14373ecc86fac5037f6c71ff4ccedd9a421.tar
nixlib-427ae14373ecc86fac5037f6c71ff4ccedd9a421.tar.gz
nixlib-427ae14373ecc86fac5037f6c71ff4ccedd9a421.tar.bz2
nixlib-427ae14373ecc86fac5037f6c71ff4ccedd9a421.tar.lz
nixlib-427ae14373ecc86fac5037f6c71ff4ccedd9a421.tar.xz
nixlib-427ae14373ecc86fac5037f6c71ff4ccedd9a421.tar.zst
nixlib-427ae14373ecc86fac5037f6c71ff4ccedd9a421.zip
nixos/nginx: update description in compression modules
Diffstat (limited to 'nixos/modules/services/web-servers/nginx/default.nix')
-rw-r--r--nixos/modules/services/web-servers/nginx/default.nix20
1 files changed, 12 insertions, 8 deletions
diff --git a/nixos/modules/services/web-servers/nginx/default.nix b/nixos/modules/services/web-servers/nginx/default.nix
index 064c86a9a7e2..7fe1c120f5b1 100644
--- a/nixos/modules/services/web-servers/nginx/default.nix
+++ b/nixos/modules/services/web-servers/nginx/default.nix
@@ -184,8 +184,9 @@ let
         brotli_types ${lib.concatStringsSep " " compressMimeTypes};
       ''}
 
-      ${optionalString cfg.recommendedGzipSettings ''
+      ${optionalString cfg.recommendedGzipSettings
         # https://docs.nginx.com/nginx/admin-guide/web-server/compression/
+      ''
         gzip on;
         gzip_static on;
         gzip_vary on;
@@ -476,7 +477,8 @@ in
         default = false;
         type = types.bool;
         description = lib.mdDoc ''
-          Enable recommended brotli settings. Learn more about compression in Brotli format [here](https://github.com/google/ngx_brotli/blob/master/README.md).
+          Enable recommended brotli settings.
+          Learn more about compression in Brotli format [here](https://github.com/google/ngx_brotli/).
 
           This adds `pkgs.nginxModules.brotli` to `services.nginx.additionalModules`.
         '';
@@ -487,24 +489,26 @@ in
         type = types.bool;
         description = lib.mdDoc ''
           Enable recommended gzip settings.
+          Learn more about compression in Gzip format [here](https://docs.nginx.com/nginx/admin-guide/web-server/compression/).
         '';
       };
 
-      recommendedProxySettings = mkOption {
+      recommendedZstdSettings = mkOption {
         default = false;
         type = types.bool;
         description = lib.mdDoc ''
-          Whether to enable recommended proxy settings if a vhost does not specify the option manually.
+          Enable recommended zstd settings.
+          Learn more about compression in Zstd format [here](https://github.com/tokers/zstd-nginx-module).
+
+          This adds `pkgs.nginxModules.zstd` to `services.nginx.additionalModules`.
         '';
       };
 
-      recommendedZstdSettings = mkOption {
+      recommendedProxySettings = mkOption {
         default = false;
         type = types.bool;
         description = lib.mdDoc ''
-          Enable recommended zstd settings. Learn more about compression in Zstd format [here](https://github.com/tokers/zstd-nginx-module).
-
-          This adds `pkgs.nginxModules.zstd` to `services.nginx.additionalModules`.
+          Whether to enable recommended proxy settings if a vhost does not specify the option manually.
         '';
       };