about summary refs log tree commit diff
path: root/nixos/modules/services/web-servers/apache-httpd/zabbix.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-14 16:26:48 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-14 16:26:48 +0200
commit29027fd1e12461fc5ff5722bea79df7ff4299599 (patch)
treefec0d7ba9f295be106fcf41759cee8b94d79dc9d /nixos/modules/services/web-servers/apache-httpd/zabbix.nix
parent4f2aa2f7061984fa7aa21bac92ed5eec3f3daa06 (diff)
downloadnixlib-29027fd1e12461fc5ff5722bea79df7ff4299599.tar
nixlib-29027fd1e12461fc5ff5722bea79df7ff4299599.tar.gz
nixlib-29027fd1e12461fc5ff5722bea79df7ff4299599.tar.bz2
nixlib-29027fd1e12461fc5ff5722bea79df7ff4299599.tar.lz
nixlib-29027fd1e12461fc5ff5722bea79df7ff4299599.tar.xz
nixlib-29027fd1e12461fc5ff5722bea79df7ff4299599.tar.zst
nixlib-29027fd1e12461fc5ff5722bea79df7ff4299599.zip
Rewrite ‘with pkgs.lib’ -> ‘with lib’
Using pkgs.lib on the spine of module evaluation is problematic
because the pkgs argument depends on the result of module
evaluation. To prevent an infinite recursion, pkgs and some of the
modules are evaluated twice, which is inefficient. Using ‘with lib’
prevents this problem.
Diffstat (limited to 'nixos/modules/services/web-servers/apache-httpd/zabbix.nix')
-rw-r--r--nixos/modules/services/web-servers/apache-httpd/zabbix.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/nixos/modules/services/web-servers/apache-httpd/zabbix.nix b/nixos/modules/services/web-servers/apache-httpd/zabbix.nix
index a6e6042fdf6d..cab16593bcbc 100644
--- a/nixos/modules/services/web-servers/apache-httpd/zabbix.nix
+++ b/nixos/modules/services/web-servers/apache-httpd/zabbix.nix
@@ -1,4 +1,6 @@
-{ config, pkgs, serverInfo, ... }:
+{ config, lib, pkgs, serverInfo, ... }:
+
+with lib;
 
 let
 
@@ -51,7 +53,7 @@ in
 
   options = {
 
-    urlPrefix = pkgs.lib.mkOption {
+    urlPrefix = mkOption {
       default = "/zabbix";
       description = "
         The URL prefix under which the Zabbix service appears.
@@ -59,9 +61,9 @@ in
       ";
     };
 
-    configFile = pkgs.lib.mkOption {
+    configFile = mkOption {
       default = null;
-      type = with pkgs.lib.types; nullOr path;
+      type = types.nullOr types.path;
       description = ''
         The configuration file (zabbix.conf.php) which contains the database
         connection settings. If not set, the configuration settings will created
@@ -69,7 +71,7 @@ in
       '';
     };
 
-    stateDir = pkgs.lib.mkOption {
+    stateDir = mkOption {
       default = "/var/lib/zabbix/frontend";
       description = "
         Directory where the dynamically generated configuration data