about summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/youtrack.nix
diff options
context:
space:
mode:
authorSilvan Mosberger <infinisil@icloud.com>2019-08-08 22:48:27 +0200
committerSilvan Mosberger <infinisil@icloud.com>2019-08-31 18:19:00 +0200
commit478e7184f88db1364cc75107036f7c4decc0cc41 (patch)
tree5ff3d3a18e3aef9af4333c392a94751333754270 /nixos/modules/services/web-apps/youtrack.nix
parent69d58ee24506e2b3b5aff347ae3b0791110340ec (diff)
downloadnixlib-478e7184f88db1364cc75107036f7c4decc0cc41.tar
nixlib-478e7184f88db1364cc75107036f7c4decc0cc41.tar.gz
nixlib-478e7184f88db1364cc75107036f7c4decc0cc41.tar.bz2
nixlib-478e7184f88db1364cc75107036f7c4decc0cc41.tar.lz
nixlib-478e7184f88db1364cc75107036f7c4decc0cc41.tar.xz
nixlib-478e7184f88db1364cc75107036f7c4decc0cc41.tar.zst
nixlib-478e7184f88db1364cc75107036f7c4decc0cc41.zip
nixos/modules: Remove all usages of types.string
And replace them with a more appropriate type

Also fix up some minor module problems along the way
Diffstat (limited to 'nixos/modules/services/web-apps/youtrack.nix')
-rw-r--r--nixos/modules/services/web-apps/youtrack.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/nixos/modules/services/web-apps/youtrack.nix b/nixos/modules/services/web-apps/youtrack.nix
index 691cbdc8d1d5..830edac20bac 100644
--- a/nixos/modules/services/web-apps/youtrack.nix
+++ b/nixos/modules/services/web-apps/youtrack.nix
@@ -28,28 +28,28 @@ in
         The interface youtrack will listen on.
       '';
       default = "127.0.0.1";
-      type = types.string;
+      type = types.str;
     };
 
     baseUrl = mkOption {
       description = ''
         Base URL for youtrack. Will be auto-detected and stored in database.
       '';
-      type = types.nullOr types.string;
+      type = types.nullOr types.str;
       default = null;
     };
 
     extraParams = mkOption {
       default = {};
       description = ''
-        Extra parameters to pass to youtrack. See 
+        Extra parameters to pass to youtrack. See
         https://www.jetbrains.com/help/youtrack/standalone/YouTrack-Java-Start-Parameters.html
         for more information.
       '';
       example = {
         "jetbrains.youtrack.overrideRootPassword" = "tortuga";
       };
-      type = types.attrsOf types.string;
+      type = types.attrsOf types.str;
     };
 
     package = mkOption {
@@ -73,7 +73,7 @@ in
       description = ''
         Where to keep the youtrack database.
       '';
-      type = types.string;
+      type = types.path;
       default = "/var/lib/youtrack";
     };
 
@@ -83,7 +83,7 @@ in
         If null, do not setup anything.
       '';
       default = null;
-      type = types.nullOr types.string;
+      type = types.nullOr types.str;
     };
 
     jvmOpts = mkOption {
@@ -92,7 +92,7 @@ in
         See https://www.jetbrains.com/help/youtrack/standalone/Configure-JVM-Options.html
         for more information.
       '';
-      type = types.string;
+      type = types.separatedString " ";
       example = "-XX:MetaspaceSize=250m";
       default = "";
     };
@@ -101,7 +101,7 @@ in
       description = ''
         Maximum Java heap size
       '';
-      type = types.string;
+      type = types.str;
       default = "1g";
     };
 
@@ -109,7 +109,7 @@ in
       description = ''
         Maximum java Metaspace memory.
       '';
-      type = types.string;
+      type = types.str;
       default = "350m";
     };
   };