about summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/snipe-it.nix
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2022-08-02 02:47:05 +0200
committerpennae <github@quasiparticle.net>2022-08-03 21:03:23 +0200
commit16102dce2fbad670bd47dd75c860a8daa5fe47ad (patch)
tree26fa9aed51c066b5145eae0d87f4ba387e3ecd48 /nixos/modules/services/web-apps/snipe-it.nix
parent694d5b19d30bf66687b42fb77f43ea7cd1002a62 (diff)
downloadnixlib-16102dce2fbad670bd47dd75c860a8daa5fe47ad.tar
nixlib-16102dce2fbad670bd47dd75c860a8daa5fe47ad.tar.gz
nixlib-16102dce2fbad670bd47dd75c860a8daa5fe47ad.tar.bz2
nixlib-16102dce2fbad670bd47dd75c860a8daa5fe47ad.tar.lz
nixlib-16102dce2fbad670bd47dd75c860a8daa5fe47ad.tar.xz
nixlib-16102dce2fbad670bd47dd75c860a8daa5fe47ad.tar.zst
nixlib-16102dce2fbad670bd47dd75c860a8daa5fe47ad.zip
nixos/*: replace <code> in option docs with <literal>
markdown can't represent the difference without another extension and
both the html manual and the manpage render them the same, so keeping the
distinction is not very useful on its own. with the distinction removed
we can automatically convert many options that use <code> tags to markdown.

the manpage remains unchanged, html manual does not render
differently (but class names on code tags do change from "code" to "literal").
Diffstat (limited to 'nixos/modules/services/web-apps/snipe-it.nix')
-rw-r--r--nixos/modules/services/web-apps/snipe-it.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/web-apps/snipe-it.nix b/nixos/modules/services/web-apps/snipe-it.nix
index 842e0715c025..3059e67cb43b 100644
--- a/nixos/modules/services/web-apps/snipe-it.nix
+++ b/nixos/modules/services/web-apps/snipe-it.nix
@@ -46,7 +46,7 @@ in {
       description = ''
         A file containing the Laravel APP_KEY - a 32 character long,
         base64 encoded key used for encryption where needed. Can be
-        generated with <code>head -c 32 /dev/urandom | base64</code>.
+        generated with <literal>head -c 32 /dev/urandom | base64</literal>.
       '';
       example = "/run/keys/snipe-it/appkey";
       type = types.path;
@@ -69,7 +69,7 @@ in {
       description = ''
         The root URL that you want to host Snipe-IT on. All URLs in Snipe-IT will be generated using this value.
         If you change this in the future you may need to run a command to update stored URLs in the database.
-        Command example: <code>snipe-it snipe-it:update-url https://old.example.com https://new.example.com</code>
+        Command example: <literal>snipe-it snipe-it:update-url https://old.example.com https://new.example.com</literal>
       '';
       default = "http${lib.optionalString tlsEnabled "s"}://${cfg.hostName}";
       defaultText = ''