about summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/peertube.nix
diff options
context:
space:
mode:
authorFelix Buehler <account@buehler.rocks>2023-06-24 20:19:19 +0200
committerFelix Buehler <account@buehler.rocks>2023-06-24 20:19:19 +0200
commitf3719756b550113c1acbbab00c89a56fb77256f2 (patch)
treea94f6678f9b1b25c6773bdd7a35422aabc816032 /nixos/modules/services/web-apps/peertube.nix
parente9e3f2e7362aba3ef709173d1777f0b893fc0ebf (diff)
downloadnixlib-f3719756b550113c1acbbab00c89a56fb77256f2.tar
nixlib-f3719756b550113c1acbbab00c89a56fb77256f2.tar.gz
nixlib-f3719756b550113c1acbbab00c89a56fb77256f2.tar.bz2
nixlib-f3719756b550113c1acbbab00c89a56fb77256f2.tar.lz
nixlib-f3719756b550113c1acbbab00c89a56fb77256f2.tar.xz
nixlib-f3719756b550113c1acbbab00c89a56fb77256f2.tar.zst
nixlib-f3719756b550113c1acbbab00c89a56fb77256f2.zip
treewide: use optionalString instead of 'then ""'
Diffstat (limited to 'nixos/modules/services/web-apps/peertube.nix')
-rw-r--r--nixos/modules/services/web-apps/peertube.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/web-apps/peertube.nix b/nixos/modules/services/web-apps/peertube.nix
index 4ef2d7dce532..8a1fc3c567cc 100644
--- a/nixos/modules/services/web-apps/peertube.nix
+++ b/nixos/modules/services/web-apps/peertube.nix
@@ -350,7 +350,7 @@ in {
         };
         redis = {
           hostname = "${toString cfg.redis.host}";
-          port = (if cfg.redis.port == null then "" else cfg.redis.port);
+          port = (lib.optionalString (cfg.redis.port != null) cfg.redis.port);
         };
         storage = {
           tmp = lib.mkDefault "/var/lib/peertube/storage/tmp/";