about summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/peertube.nix
diff options
context:
space:
mode:
authorSandro Jäckel <sandro.jaeckel@gmail.com>2022-11-06 11:59:21 +0100
committerSandro Jäckel <sandro.jaeckel@gmail.com>2023-04-25 11:28:17 +0200
commitaad577bd30b0ab16a7859973c88edd6d0d5becde (patch)
tree7f24e0060e8644031402d0e2770ca080aeea4f7a /nixos/modules/services/web-apps/peertube.nix
parent1c6cb4cabd84351cbc2dbc2dec4f5636a75f543a (diff)
downloadnixlib-aad577bd30b0ab16a7859973c88edd6d0d5becde.tar
nixlib-aad577bd30b0ab16a7859973c88edd6d0d5becde.tar.gz
nixlib-aad577bd30b0ab16a7859973c88edd6d0d5becde.tar.bz2
nixlib-aad577bd30b0ab16a7859973c88edd6d0d5becde.tar.lz
nixlib-aad577bd30b0ab16a7859973c88edd6d0d5becde.tar.xz
nixlib-aad577bd30b0ab16a7859973c88edd6d0d5becde.tar.zst
nixlib-aad577bd30b0ab16a7859973c88edd6d0d5becde.zip
nodejs*: normalise names to better fit other packages
Versioned package attributes are usually named like $pname_$version
eg: nodejs-14_x -> nodejs_14
Diffstat (limited to 'nixos/modules/services/web-apps/peertube.nix')
-rw-r--r--nixos/modules/services/web-apps/peertube.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/web-apps/peertube.nix b/nixos/modules/services/web-apps/peertube.nix
index 7e418f2869c8..65b3b70c48ad 100644
--- a/nixos/modules/services/web-apps/peertube.nix
+++ b/nixos/modules/services/web-apps/peertube.nix
@@ -429,7 +429,7 @@ in {
 
       environment = env;
 
-      path = with pkgs; [ bashInteractive ffmpeg nodejs-16_x openssl yarn python3 ];
+      path = with pkgs; [ bashInteractive ffmpeg nodejs_16 openssl yarn python3 ];
 
       script = ''
         #!/bin/sh
@@ -859,7 +859,7 @@ in {
           home = cfg.package;
         };
       })
-      (lib.attrsets.setAttrByPath [ cfg.user "packages" ] [ cfg.package peertubeEnv peertubeCli pkgs.ffmpeg pkgs.nodejs-16_x pkgs.yarn ])
+      (lib.attrsets.setAttrByPath [ cfg.user "packages" ] [ cfg.package peertubeEnv peertubeCli pkgs.ffmpeg pkgs.nodejs_16 pkgs.yarn ])
       (lib.mkIf cfg.redis.enableUnixSocket {${config.services.peertube.user}.extraGroups = [ "redis-peertube" ];})
     ];