about summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/peertube.nix
diff options
context:
space:
mode:
authorAndrew Morgan <andrew@amorgan.xyz>2023-11-19 20:39:27 +0000
committerBjørn Forsman <bjorn.forsman@gmail.com>2023-11-22 21:15:36 +0100
commit54b7a396467dda279a5d2471b46900a75d5113db (patch)
tree99bb28b50cb08ee1d768b1c50220035dd5d3e136 /nixos/modules/services/web-apps/peertube.nix
parent7af2e245a661940fd61b8031439f0a0ad8939d17 (diff)
downloadnixlib-54b7a396467dda279a5d2471b46900a75d5113db.tar
nixlib-54b7a396467dda279a5d2471b46900a75d5113db.tar.gz
nixlib-54b7a396467dda279a5d2471b46900a75d5113db.tar.bz2
nixlib-54b7a396467dda279a5d2471b46900a75d5113db.tar.lz
nixlib-54b7a396467dda279a5d2471b46900a75d5113db.tar.xz
nixlib-54b7a396467dda279a5d2471b46900a75d5113db.tar.zst
nixlib-54b7a396467dda279a5d2471b46900a75d5113db.zip
peertube: Clarify option descriptions of `listenHttp`, `listenWeb`, `enableWebHttps`
Diffstat (limited to 'nixos/modules/services/web-apps/peertube.nix')
-rw-r--r--nixos/modules/services/web-apps/peertube.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/modules/services/web-apps/peertube.nix b/nixos/modules/services/web-apps/peertube.nix
index a22467611410..39c02c81c423 100644
--- a/nixos/modules/services/web-apps/peertube.nix
+++ b/nixos/modules/services/web-apps/peertube.nix
@@ -100,19 +100,19 @@ in {
     listenHttp = lib.mkOption {
       type = lib.types.port;
       default = 9000;
-      description = lib.mdDoc "listen port for HTTP server.";
+      description = lib.mdDoc "The port that the local PeerTube web server will listen on.";
     };
 
     listenWeb = lib.mkOption {
       type = lib.types.port;
       default = 9000;
-      description = lib.mdDoc "listen port for WEB server.";
+      description = lib.mdDoc "The public-facing port that PeerTube will be accessible at (likely 80 or 443 if running behind a reverse proxy). Clients will try to access PeerTube at this port.";
     };
 
     enableWebHttps = lib.mkOption {
       type = lib.types.bool;
       default = false;
-      description = lib.mdDoc "Enable or disable HTTPS protocol.";
+      description = lib.mdDoc "Whether clients will access your PeerTube instance with HTTPS. Does NOT configure the PeerTube webserver itself to listen for incoming HTTPS connections.";
     };
 
     dataDirs = lib.mkOption {
@@ -279,7 +279,7 @@ in {
       type = lib.types.package;
       default = pkgs.peertube;
       defaultText = lib.literalExpression "pkgs.peertube";
-      description = lib.mdDoc "Peertube package to use.";
+      description = lib.mdDoc "PeerTube package to use.";
     };
   };