about summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/peertube.nix
diff options
context:
space:
mode:
authorFelix Bühler <Stunkymonkey@users.noreply.github.com>2023-07-22 13:02:47 +0200
committerGitHub <noreply@github.com>2023-07-22 13:02:47 +0200
commit0a2745684e8e97340d947d56b0ba778056c10395 (patch)
treec258179185eefafddef480949e84046d3bb50b2e /nixos/modules/services/web-apps/peertube.nix
parent4448ec5cd84f00350969934deb4d9ac9055c411c (diff)
parente770737241360cdfd09b421eea83160dce02c212 (diff)
downloadnixlib-0a2745684e8e97340d947d56b0ba778056c10395.tar
nixlib-0a2745684e8e97340d947d56b0ba778056c10395.tar.gz
nixlib-0a2745684e8e97340d947d56b0ba778056c10395.tar.bz2
nixlib-0a2745684e8e97340d947d56b0ba778056c10395.tar.lz
nixlib-0a2745684e8e97340d947d56b0ba778056c10395.tar.xz
nixlib-0a2745684e8e97340d947d56b0ba778056c10395.tar.zst
nixlib-0a2745684e8e97340d947d56b0ba778056c10395.zip
Merge pull request #239624 from Stunkymonkey/use-optionalString-then
treewide: use optionalString instead of 'then ""'
Diffstat (limited to 'nixos/modules/services/web-apps/peertube.nix')
-rw-r--r--nixos/modules/services/web-apps/peertube.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/web-apps/peertube.nix b/nixos/modules/services/web-apps/peertube.nix
index 4826b2cab6a3..17e170c33dee 100644
--- a/nixos/modules/services/web-apps/peertube.nix
+++ b/nixos/modules/services/web-apps/peertube.nix
@@ -348,7 +348,7 @@ in {
         };
         redis = {
           hostname = "${toString cfg.redis.host}";
-          port = (if cfg.redis.port == null then "" else cfg.redis.port);
+          port = (lib.optionalString (cfg.redis.port != null) cfg.redis.port);
         };
         storage = {
           tmp = lib.mkDefault "/var/lib/peertube/storage/tmp/";