about summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/meme-bingo-web.nix
diff options
context:
space:
mode:
authorh7x4 <h7x4@nani.wtf>2023-11-27 01:19:27 +0100
committerh7x4 <h7x4@nani.wtf>2023-11-27 01:28:36 +0100
commit0a37316d6cfea44280f4470b6867a711a24606bd (patch)
tree0dce949073e1f1647975a2ec3adfb7facdbb8ac4 /nixos/modules/services/web-apps/meme-bingo-web.nix
parent9cc575741df943328b2dbbf6ef7c5dfd49c1bbe0 (diff)
downloadnixlib-0a37316d6cfea44280f4470b6867a711a24606bd.tar
nixlib-0a37316d6cfea44280f4470b6867a711a24606bd.tar.gz
nixlib-0a37316d6cfea44280f4470b6867a711a24606bd.tar.bz2
nixlib-0a37316d6cfea44280f4470b6867a711a24606bd.tar.lz
nixlib-0a37316d6cfea44280f4470b6867a711a24606bd.tar.xz
nixlib-0a37316d6cfea44280f4470b6867a711a24606bd.tar.zst
nixlib-0a37316d6cfea44280f4470b6867a711a24606bd.zip
treewide: use `mkPackageOption`
This commit replaces a lot of usages of `mkOption` with the package
type, to be `mkPackageOption`, in order to reduce the amount of code.
Diffstat (limited to 'nixos/modules/services/web-apps/meme-bingo-web.nix')
-rw-r--r--nixos/modules/services/web-apps/meme-bingo-web.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/nixos/modules/services/web-apps/meme-bingo-web.nix b/nixos/modules/services/web-apps/meme-bingo-web.nix
index 652dc8840252..fe68bbecca57 100644
--- a/nixos/modules/services/web-apps/meme-bingo-web.nix
+++ b/nixos/modules/services/web-apps/meme-bingo-web.nix
@@ -1,7 +1,7 @@
 { config, lib, pkgs, ... }:
 
 let
-  inherit (lib) mkEnableOption mkIf mkOption mdDoc types literalExpression;
+  inherit (lib) mkEnableOption mkPackageOption mkIf mkOption mdDoc types literalExpression;
 
   cfg = config.services.meme-bingo-web;
 in {
@@ -13,12 +13,7 @@ in {
         Note: The application's author suppose to run meme-bingo-web behind a reverse proxy for SSL and HTTP/3
       '');
 
-      package = mkOption {
-        type = types.package;
-        default = pkgs.meme-bingo-web;
-        defaultText = literalExpression "pkgs.meme-bingo-web";
-        description = mdDoc "meme-bingo-web package to use.";
-      };
+      package = mkPackageOption pkgs "meme-bingo-web" { };
 
       baseUrl = mkOption {
         description = mdDoc ''