about summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/mattermost.nix
diff options
context:
space:
mode:
authorrnhmjoj <rnhmjoj@inventati.org>2019-09-14 19:51:29 +0200
committerworldofpeace <worldofpeace@protonmail.ch>2020-01-06 10:39:18 -0500
commit1d61efb7f177f7b70c467ab4940fde0a3481d4dc (patch)
tree860cce85acd87bc07aa2d11f4feac5d0df48a5c0 /nixos/modules/services/web-apps/mattermost.nix
parent6bd13ccd8e7fd1f241eb655f7112df1ed2889a3a (diff)
downloadnixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.gz
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.bz2
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.lz
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.xz
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.zst
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.zip
treewide: use attrs instead of list for types.loaOf options
Diffstat (limited to 'nixos/modules/services/web-apps/mattermost.nix')
-rw-r--r--nixos/modules/services/web-apps/mattermost.nix22
1 files changed, 11 insertions, 11 deletions
diff --git a/nixos/modules/services/web-apps/mattermost.nix b/nixos/modules/services/web-apps/mattermost.nix
index 8c7fc4056adc..41c52b9653bf 100644
--- a/nixos/modules/services/web-apps/mattermost.nix
+++ b/nixos/modules/services/web-apps/mattermost.nix
@@ -146,17 +146,17 @@ in
 
   config = mkMerge [
     (mkIf cfg.enable {
-      users.users = optionalAttrs (cfg.user == "mattermost") (singleton {
-        name = "mattermost";
-        group = cfg.group;
-        uid = config.ids.uids.mattermost;
-        home = cfg.statePath;
-      });
-
-      users.groups = optionalAttrs (cfg.group == "mattermost") (singleton {
-        name = "mattermost";
-        gid = config.ids.gids.mattermost;
-      });
+      users.users = optionalAttrs (cfg.user == "mattermost") {
+        mattermost = {
+          group = cfg.group;
+          uid = config.ids.uids.mattermost;
+          home = cfg.statePath;
+        };
+      };
+
+      users.groups = optionalAttrs (cfg.group == "mattermost") {
+        mattermost.gid = config.ids.gids.mattermost;
+      };
 
       services.postgresql.enable = cfg.localDatabaseCreate;