about summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/limesurvey.nix
diff options
context:
space:
mode:
authorThomas Gerbet <thomas@gerbet.me>2023-05-16 19:18:22 +0200
committerThomas Gerbet <thomas@gerbet.me>2023-05-16 19:18:22 +0200
commitbc48fa8f5e3c09b1c401b21388f2f429df1ad536 (patch)
tree166e909ecc7d442879ceadbcc98c16e4fccce72c /nixos/modules/services/web-apps/limesurvey.nix
parent314c64c409455ee49665ab2c7262b28965d17390 (diff)
downloadnixlib-bc48fa8f5e3c09b1c401b21388f2f429df1ad536.tar
nixlib-bc48fa8f5e3c09b1c401b21388f2f429df1ad536.tar.gz
nixlib-bc48fa8f5e3c09b1c401b21388f2f429df1ad536.tar.bz2
nixlib-bc48fa8f5e3c09b1c401b21388f2f429df1ad536.tar.lz
nixlib-bc48fa8f5e3c09b1c401b21388f2f429df1ad536.tar.xz
nixlib-bc48fa8f5e3c09b1c401b21388f2f429df1ad536.tar.zst
nixlib-bc48fa8f5e3c09b1c401b21388f2f429df1ad536.zip
limesurvey: mark as broken
limesurvey is not yet compatible with PHP 8.1.
Diffstat (limited to 'nixos/modules/services/web-apps/limesurvey.nix')
-rw-r--r--nixos/modules/services/web-apps/limesurvey.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/services/web-apps/limesurvey.nix b/nixos/modules/services/web-apps/limesurvey.nix
index 8e6b39cbdebc..920e6928ef5c 100644
--- a/nixos/modules/services/web-apps/limesurvey.nix
+++ b/nixos/modules/services/web-apps/limesurvey.nix
@@ -226,7 +226,7 @@ in
 
     services.phpfpm.pools.limesurvey = {
       inherit user group;
-      phpPackage = pkgs.php80;
+      phpPackage = pkgs.php81;
       phpEnv.DBENGINE = "${cfg.database.dbEngine}";
       phpEnv.LIMESURVEY_CONFIG = "${limesurveyConfig}";
       settings = {
@@ -288,8 +288,8 @@ in
       environment.LIMESURVEY_CONFIG = limesurveyConfig;
       script = ''
         # update or install the database as required
-        ${pkgs.php80}/bin/php ${pkg}/share/limesurvey/application/commands/console.php updatedb || \
-        ${pkgs.php80}/bin/php ${pkg}/share/limesurvey/application/commands/console.php install admin password admin admin@example.com verbose
+        ${pkgs.php81}/bin/php ${pkg}/share/limesurvey/application/commands/console.php updatedb || \
+        ${pkgs.php81}/bin/php ${pkg}/share/limesurvey/application/commands/console.php install admin password admin admin@example.com verbose
       '';
       serviceConfig = {
         User = user;