about summary refs log tree commit diff
path: root/nixos/modules/services/networking/yggdrasil.nix
diff options
context:
space:
mode:
authorMartin Puppe <dev@mpuppe.de>2023-01-31 09:58:50 +0100
committerMartin Puppe <dev@mpuppe.de>2023-02-20 23:10:54 +0100
commit8bc615d0e089f302f787a115f907105a367f0300 (patch)
tree242c39bdb071759eed5308bcd6813596a0b0a81f /nixos/modules/services/networking/yggdrasil.nix
parentcf8b1fb85ecf75b836b881dc5a50dd1f88926d2a (diff)
downloadnixlib-8bc615d0e089f302f787a115f907105a367f0300.tar
nixlib-8bc615d0e089f302f787a115f907105a367f0300.tar.gz
nixlib-8bc615d0e089f302f787a115f907105a367f0300.tar.bz2
nixlib-8bc615d0e089f302f787a115f907105a367f0300.tar.lz
nixlib-8bc615d0e089f302f787a115f907105a367f0300.tar.xz
nixlib-8bc615d0e089f302f787a115f907105a367f0300.tar.zst
nixlib-8bc615d0e089f302f787a115f907105a367f0300.zip
nixos/yggdrasil: correct documentation
The option `LinkLocalTCPPort` does not exist anymore in recent versions
of Yggdrasil. The port for incoming link-local connections is now
configured as part of the `MulticastInterfaces` option. Our
documentation should reflect that.
Diffstat (limited to 'nixos/modules/services/networking/yggdrasil.nix')
-rw-r--r--nixos/modules/services/networking/yggdrasil.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/nixos/modules/services/networking/yggdrasil.nix b/nixos/modules/services/networking/yggdrasil.nix
index 0af78327b207..55a6002d61af 100644
--- a/nixos/modules/services/networking/yggdrasil.nix
+++ b/nixos/modules/services/networking/yggdrasil.nix
@@ -46,7 +46,7 @@ in
 
           If no keys are specified then ephemeral keys are generated
           and the Yggdrasil interface will have a random IPv6 address
-          each time the service is started, this is the default.
+          each time the service is started. This is the default.
 
           If both {option}`configFile` and {option}`settings`
           are supplied, they will be combined, with values from
@@ -83,14 +83,14 @@ in
         type = bool;
         default = false;
         description = lib.mdDoc ''
-          Whether to open the UDP port used for multicast peer
-          discovery. The NixOS firewall blocks link-local
-          communication, so in order to make local peering work you
-          will also need to set `LinkLocalTCPPort` in your
-          yggdrasil configuration ({option}`settings` or
-          {option}`configFile`) to a port number other than 0,
-          and then add that port to
-          {option}`networking.firewall.allowedTCPPorts`.
+          Whether to open the UDP port used for multicast peer discovery. The
+          NixOS firewall blocks link-local communication, so in order to make
+          incoming local peering work you will also need to configure
+          `MulticastInterfaces` in your Yggdrasil configuration
+          ({option}`settings` or {option}`configFile`). You will then have to
+          add the ports that you configure there to your firewall configuration
+          ({option}`networking.firewall.allowedTCPPorts` or
+          {option}`networking.firewall.interfaces.<name>.allowedTCPPorts`).
         '';
       };