about summary refs log tree commit diff
path: root/nixos/modules/services/networking/xrdp.nix
diff options
context:
space:
mode:
authorMichael Peyton Jones <me@michaelpj.com>2018-08-15 09:55:35 +0100
committerMichael Peyton Jones <me@michaelpj.com>2018-08-16 21:23:34 +0100
commit13e2e19158bcd2b4d53e452d82f62817194100ef (patch)
tree71a13eecf2ba743d8df7a57c3dc577dd4ae9d630 /nixos/modules/services/networking/xrdp.nix
parent52e7817aa2c33b8569b6fdc884f98a34fbf6f61e (diff)
downloadnixlib-13e2e19158bcd2b4d53e452d82f62817194100ef.tar
nixlib-13e2e19158bcd2b4d53e452d82f62817194100ef.tar.gz
nixlib-13e2e19158bcd2b4d53e452d82f62817194100ef.tar.bz2
nixlib-13e2e19158bcd2b4d53e452d82f62817194100ef.tar.lz
nixlib-13e2e19158bcd2b4d53e452d82f62817194100ef.tar.xz
nixlib-13e2e19158bcd2b4d53e452d82f62817194100ef.tar.zst
nixlib-13e2e19158bcd2b4d53e452d82f62817194100ef.zip
xdg: add modules for supporting various XDG specs
Diffstat (limited to 'nixos/modules/services/networking/xrdp.nix')
-rw-r--r--nixos/modules/services/networking/xrdp.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/nixos/modules/services/networking/xrdp.nix b/nixos/modules/services/networking/xrdp.nix
index 0e882873b4ba..61f22a366a02 100644
--- a/nixos/modules/services/networking/xrdp.nix
+++ b/nixos/modules/services/networking/xrdp.nix
@@ -93,10 +93,14 @@ in
 
   config = mkIf cfg.enable {
 
-    # copied from <nixos/modules/services/x11/xserver.nix>
     # xrdp can run X11 program even if "services.xserver.enable = false"
-    environment.pathsToLink =
-      [ "/etc/xdg" "/share/xdg" "/share/applications" "/share/icons" "/share/pixmaps" ];
+    xdg = {
+      autostart.enable = true;
+      menus.enable = true;
+      mime.enable = true;
+      icons.enable = true;
+    };
+
     fonts.enableDefaultFonts = mkDefault true;
 
     systemd = {