about summary refs log tree commit diff
path: root/nixos/modules/services/networking/wicd.nix
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2016-01-06 06:50:18 +0000
committerRobin Gloster <mail@glob.in>2016-01-07 06:39:06 +0000
commit88292fdf09960e9cb8e3c063a6b95ac4284222ec (patch)
tree34ff267ed7bacf9fd906b1736476b431e9afe909 /nixos/modules/services/networking/wicd.nix
parentaf50b03f50d88954e98018c7c18c0581928b7165 (diff)
downloadnixlib-88292fdf09960e9cb8e3c063a6b95ac4284222ec.tar
nixlib-88292fdf09960e9cb8e3c063a6b95ac4284222ec.tar.gz
nixlib-88292fdf09960e9cb8e3c063a6b95ac4284222ec.tar.bz2
nixlib-88292fdf09960e9cb8e3c063a6b95ac4284222ec.tar.lz
nixlib-88292fdf09960e9cb8e3c063a6b95ac4284222ec.tar.xz
nixlib-88292fdf09960e9cb8e3c063a6b95ac4284222ec.tar.zst
nixlib-88292fdf09960e9cb8e3c063a6b95ac4284222ec.zip
jobs -> systemd.services
Diffstat (limited to 'nixos/modules/services/networking/wicd.nix')
-rw-r--r--nixos/modules/services/networking/wicd.nix14
1 files changed, 5 insertions, 9 deletions
diff --git a/nixos/modules/services/networking/wicd.nix b/nixos/modules/services/networking/wicd.nix
index 18258084fc2c..9e5a437b4856 100644
--- a/nixos/modules/services/networking/wicd.nix
+++ b/nixos/modules/services/networking/wicd.nix
@@ -25,17 +25,13 @@ with lib;
 
     environment.systemPackages = [pkgs.wicd];
 
-    jobs.wicd =
-      { startOn = "started network-interfaces";
-        stopOn = "stopping network-interfaces";
-
-        script =
-          "${pkgs.wicd}/sbin/wicd -f";
-      };
+    systemd.services.wicd = {
+      after = [ "network-interfaces.target" ];
+      wantedBy = [ "multi-user.target" ];
+      script = "${pkgs.wicd}/sbin/wicd -f";
+    };
 
     services.dbus.enable = true;
     services.dbus.packages = [pkgs.wicd];
-
   };
-
 }