about summary refs log tree commit diff
path: root/nixos/modules/services/networking/tinc.nix
diff options
context:
space:
mode:
authorThomas Strobel <ts468@cam.ac.uk>2016-01-17 19:34:55 +0100
committerThomas Strobel <ts468@cam.ac.uk>2016-01-17 19:41:23 +0100
commita04a7272aa38ada45e694281071b720d4abbd0df (patch)
tree3cd20fafec2de8e3b5ec558461a779898b4e50ee /nixos/modules/services/networking/tinc.nix
parentae5ef2b00955a8b8cbcc93a6682a8275c4d5e52c (diff)
downloadnixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.gz
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.bz2
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.lz
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.xz
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.zst
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.zip
Add missing 'type', 'defaultText' and 'literalExample' in module definitions
- add missing types in module definitions
- add missing 'defaultText' in module definitions
- wrap example with 'literalExample' where necessary in module definitions
Diffstat (limited to 'nixos/modules/services/networking/tinc.nix')
-rw-r--r--nixos/modules/services/networking/tinc.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/modules/services/networking/tinc.nix b/nixos/modules/services/networking/tinc.nix
index 828bbe130e67..34f4f6b37b60 100644
--- a/nixos/modules/services/networking/tinc.nix
+++ b/nixos/modules/services/networking/tinc.nix
@@ -87,7 +87,9 @@ in
           };
 
           package = mkOption {
+            type = types.package;
             default = pkgs.tinc_pre;
+            defaultText = "pkgs.tinc_pre";
             description = ''
               The package to use for the tinc daemon's binary.
             '';