about summary refs log tree commit diff
path: root/nixos/modules/services/networking/ssh/sshd.nix
diff options
context:
space:
mode:
authordanbst <abcz2.uprola@gmail.com>2019-08-05 14:01:45 +0300
committerdanbst <abcz2.uprola@gmail.com>2019-08-05 14:01:45 +0300
commit91bb646e98808d594b339d3386f7963a546ccfb4 (patch)
tree4390925c6087d284c11183193044835152f6cea5 /nixos/modules/services/networking/ssh/sshd.nix
parent3b0534310c89d04fc3a9c5714b5a4d0f9fb0efca (diff)
downloadnixlib-91bb646e98808d594b339d3386f7963a546ccfb4.tar
nixlib-91bb646e98808d594b339d3386f7963a546ccfb4.tar.gz
nixlib-91bb646e98808d594b339d3386f7963a546ccfb4.tar.bz2
nixlib-91bb646e98808d594b339d3386f7963a546ccfb4.tar.lz
nixlib-91bb646e98808d594b339d3386f7963a546ccfb4.tar.xz
nixlib-91bb646e98808d594b339d3386f7963a546ccfb4.tar.zst
nixlib-91bb646e98808d594b339d3386f7963a546ccfb4.zip
Revert "mass replace "flip map -> foreach""
This reverts commit 3b0534310c89d04fc3a9c5714b5a4d0f9fb0efca.
Diffstat (limited to 'nixos/modules/services/networking/ssh/sshd.nix')
-rw-r--r--nixos/modules/services/networking/ssh/sshd.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/networking/ssh/sshd.nix b/nixos/modules/services/networking/ssh/sshd.nix
index 005d8bfb61fb..0f9d2420903b 100644
--- a/nixos/modules/services/networking/ssh/sshd.nix
+++ b/nixos/modules/services/networking/ssh/sshd.nix
@@ -502,7 +502,7 @@ in
 
     assertions = [{ assertion = if cfg.forwardX11 then cfgc.setXAuthLocation else true;
                     message = "cannot enable X11 forwarding without setting xauth location";}]
-      ++ foreach cfg.listenAddresses ({ addr, ... }: {
+      ++ flip map cfg.listenAddresses ({ addr, ... }: {
         assertion = addr != null;
         message = "addr must be specified in each listenAddresses entry";
       });