about summary refs log tree commit diff
path: root/nixos/modules/services/networking/openntpd.nix
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-02-04 17:26:52 -0800
committerWilliam A. Kennington III <william@wkennington.com>2015-02-04 17:27:03 -0800
commita9f1329d2d1f5bd9e151ddffd842c40313f4f190 (patch)
treed73101fc75e62b520b1fe91eba3a8b24474f71f4 /nixos/modules/services/networking/openntpd.nix
parent1dd23a28cb4179551337421bb177f0c96aa54a11 (diff)
downloadnixlib-a9f1329d2d1f5bd9e151ddffd842c40313f4f190.tar
nixlib-a9f1329d2d1f5bd9e151ddffd842c40313f4f190.tar.gz
nixlib-a9f1329d2d1f5bd9e151ddffd842c40313f4f190.tar.bz2
nixlib-a9f1329d2d1f5bd9e151ddffd842c40313f4f190.tar.lz
nixlib-a9f1329d2d1f5bd9e151ddffd842c40313f4f190.tar.xz
nixlib-a9f1329d2d1f5bd9e151ddffd842c40313f4f190.tar.zst
nixlib-a9f1329d2d1f5bd9e151ddffd842c40313f4f190.zip
nixos/openntpd: Add openntpd to the environment for ntpctl
Diffstat (limited to 'nixos/modules/services/networking/openntpd.nix')
-rw-r--r--nixos/modules/services/networking/openntpd.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/nixos/modules/services/networking/openntpd.nix b/nixos/modules/services/networking/openntpd.nix
index d1c32db49c4c..7d01246ed769 100644
--- a/nixos/modules/services/networking/openntpd.nix
+++ b/nixos/modules/services/networking/openntpd.nix
@@ -54,6 +54,9 @@ in
   config = mkIf cfg.enable {
     services.ntp.enable = mkForce false;
 
+    # Add ntpctl to the environment for status checking
+    environment.systemPackages = [ openntpd ];
+
     users.extraUsers = singleton {
       name = "ntp";
       uid = config.ids.uids.ntp;