about summary refs log tree commit diff
path: root/nixos/modules/services/networking/networkmanager.nix
diff options
context:
space:
mode:
authorJoachim F <joachifm@users.noreply.github.com>2017-12-11 23:26:21 +0000
committerGitHub <noreply@github.com>2017-12-11 23:26:21 +0000
commit90accc093e154d01881d642b3a94fe1b16a2bc00 (patch)
tree4ef19fffb3587be26698afd0825c58cd69e7c1f0 /nixos/modules/services/networking/networkmanager.nix
parente5d35342b8cd5ae2eae7af56a2d14267e0b6ace5 (diff)
parent460a4b08328a3f5f97042c8500303421a750abd6 (diff)
downloadnixlib-90accc093e154d01881d642b3a94fe1b16a2bc00.tar
nixlib-90accc093e154d01881d642b3a94fe1b16a2bc00.tar.gz
nixlib-90accc093e154d01881d642b3a94fe1b16a2bc00.tar.bz2
nixlib-90accc093e154d01881d642b3a94fe1b16a2bc00.tar.lz
nixlib-90accc093e154d01881d642b3a94fe1b16a2bc00.tar.xz
nixlib-90accc093e154d01881d642b3a94fe1b16a2bc00.tar.zst
nixlib-90accc093e154d01881d642b3a94fe1b16a2bc00.zip
Merge pull request #32216 from LumiGuide/networkmanager-strongswan
networkmanager_strongswan: fix package
Diffstat (limited to 'nixos/modules/services/networking/networkmanager.nix')
-rw-r--r--nixos/modules/services/networking/networkmanager.nix19
1 files changed, 18 insertions, 1 deletions
diff --git a/nixos/modules/services/networking/networkmanager.nix b/nixos/modules/services/networking/networkmanager.nix
index d9ac4b0f274e..62afbf32c2f6 100644
--- a/nixos/modules/services/networking/networkmanager.nix
+++ b/nixos/modules/services/networking/networkmanager.nix
@@ -241,6 +241,19 @@ in {
           A list of scripts which will be executed in response to  network  events.
         '';
       };
+
+      enableStrongSwan = mkOption {
+        type = types.bool;
+        default = false;
+        description = ''
+          Enable the StrongSwan plugin.
+          </para><para>
+          If you enable this option the
+          <literal>networkmanager_strongswan</literal> plugin will be added to
+          the <option>networking.networkmanager.packages</option> option
+          so you don't need to to that yourself.
+        '';
+      };
     };
   };
 
@@ -335,7 +348,11 @@ in {
 
     security.polkit.extraConfig = polkitConf;
 
-    services.dbus.packages = cfg.packages;
+    networking.networkmanager.packages =
+      mkIf cfg.enableStrongSwan [ pkgs.networkmanager_strongswan ];
+
+    services.dbus.packages =
+      optional cfg.enableStrongSwan pkgs.strongswanNM ++ cfg.packages;
 
     services.udev.packages = cfg.packages;
   };