about summary refs log tree commit diff
path: root/nixos/modules/services/networking/morty.nix
diff options
context:
space:
mode:
authorh7x4 <h7x4@nani.wtf>2023-11-27 01:19:27 +0100
committerh7x4 <h7x4@nani.wtf>2023-11-27 01:28:36 +0100
commit0a37316d6cfea44280f4470b6867a711a24606bd (patch)
tree0dce949073e1f1647975a2ec3adfb7facdbb8ac4 /nixos/modules/services/networking/morty.nix
parent9cc575741df943328b2dbbf6ef7c5dfd49c1bbe0 (diff)
downloadnixlib-0a37316d6cfea44280f4470b6867a711a24606bd.tar
nixlib-0a37316d6cfea44280f4470b6867a711a24606bd.tar.gz
nixlib-0a37316d6cfea44280f4470b6867a711a24606bd.tar.bz2
nixlib-0a37316d6cfea44280f4470b6867a711a24606bd.tar.lz
nixlib-0a37316d6cfea44280f4470b6867a711a24606bd.tar.xz
nixlib-0a37316d6cfea44280f4470b6867a711a24606bd.tar.zst
nixlib-0a37316d6cfea44280f4470b6867a711a24606bd.zip
treewide: use `mkPackageOption`
This commit replaces a lot of usages of `mkOption` with the package
type, to be `mkPackageOption`, in order to reduce the amount of code.
Diffstat (limited to 'nixos/modules/services/networking/morty.nix')
-rw-r--r--nixos/modules/services/networking/morty.nix7
1 files changed, 1 insertions, 6 deletions
diff --git a/nixos/modules/services/networking/morty.nix b/nixos/modules/services/networking/morty.nix
index 72514764a7c6..6954596addfd 100644
--- a/nixos/modules/services/networking/morty.nix
+++ b/nixos/modules/services/networking/morty.nix
@@ -42,12 +42,7 @@ in
         description = lib.mdDoc "Request timeout in seconds.";
       };
 
-      package = mkOption {
-        type = types.package;
-        default = pkgs.morty;
-        defaultText = literalExpression "pkgs.morty";
-        description = lib.mdDoc "morty package to use.";
-      };
+      package = mkPackageOption pkgs "morty" { };
 
       port = mkOption {
         type = types.port;