about summary refs log tree commit diff
path: root/nixos/modules/services/networking/gdomap.nix
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2016-07-07 18:54:32 +0000
committerMatthew Bauer <mjbauer95@gmail.com>2016-08-16 21:11:06 +0000
commitf54171505725c6805023d44195e9d11d2c7bbc03 (patch)
tree711c2647060952ccbd20b1e2c5cc7c169ba03ddf /nixos/modules/services/networking/gdomap.nix
parent08ce2d9d4071131e37eeb45ef4f2a585e0af0bc8 (diff)
downloadnixlib-f54171505725c6805023d44195e9d11d2c7bbc03.tar
nixlib-f54171505725c6805023d44195e9d11d2c7bbc03.tar.gz
nixlib-f54171505725c6805023d44195e9d11d2c7bbc03.tar.bz2
nixlib-f54171505725c6805023d44195e9d11d2c7bbc03.tar.lz
nixlib-f54171505725c6805023d44195e9d11d2c7bbc03.tar.xz
nixlib-f54171505725c6805023d44195e9d11d2c7bbc03.tar.zst
nixlib-f54171505725c6805023d44195e9d11d2c7bbc03.zip
gnustep: fix gdomap service
This gets rid of the rest of the pidfile stuff and makes gdomap just act
like a normal systemd process. Also reword "enable" option.
Diffstat (limited to 'nixos/modules/services/networking/gdomap.nix')
-rw-r--r--nixos/modules/services/networking/gdomap.nix15
1 files changed, 3 insertions, 12 deletions
diff --git a/nixos/modules/services/networking/gdomap.nix b/nixos/modules/services/networking/gdomap.nix
index 7f2d2159b481..b3fd91d037fa 100644
--- a/nixos/modules/services/networking/gdomap.nix
+++ b/nixos/modules/services/networking/gdomap.nix
@@ -11,8 +11,8 @@ in
   #
   options = {
     services.gdomap = {
-      enable = mkEnableOption "Whether to enable gdomap, the GNUstep distributed objects daemon";
-    };
+      enable = mkEnableOption "GNUstep Distributed Objects name server";
+   };
   };
 
   #
@@ -26,16 +26,7 @@ in
       wantedBy = [ "multi-user.target" ];
       after = [ "network.target" ];
       path  = [ pkgs.gnustep.base ];
-      serviceConfig = {
-        PIDFile = cfg.pidfile;
-        ExecStart = "@${pkgs.gnustep.base}/bin/gdomap"
-	  + " -d -p"
-	  + " -I ${cfg.pidfile}";
-	Restart = "always";
-	RestartSec = 2;
-	TimeoutStartSec = "30";
-	Type = "forking";
-      };
+      serviceConfig.ExecStart = "${pkgs.gnustep.base}/bin/gdomap -f";
     };
   };
 }