about summary refs log tree commit diff
path: root/nixos/modules/services/networking/firewall.nix
diff options
context:
space:
mode:
authorThomas Strobel <ts468@cam.ac.uk>2016-01-17 19:34:55 +0100
committerThomas Strobel <ts468@cam.ac.uk>2016-01-17 19:41:23 +0100
commita04a7272aa38ada45e694281071b720d4abbd0df (patch)
tree3cd20fafec2de8e3b5ec558461a779898b4e50ee /nixos/modules/services/networking/firewall.nix
parentae5ef2b00955a8b8cbcc93a6682a8275c4d5e52c (diff)
downloadnixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.gz
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.bz2
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.lz
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.xz
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.zst
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.zip
Add missing 'type', 'defaultText' and 'literalExample' in module definitions
- add missing types in module definitions
- add missing 'defaultText' in module definitions
- wrap example with 'literalExample' where necessary in module definitions
Diffstat (limited to 'nixos/modules/services/networking/firewall.nix')
-rw-r--r--nixos/modules/services/networking/firewall.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/services/networking/firewall.nix b/nixos/modules/services/networking/firewall.nix
index a61f0250ef8b..e11fe072be65 100644
--- a/nixos/modules/services/networking/firewall.nix
+++ b/nixos/modules/services/networking/firewall.nix
@@ -421,8 +421,9 @@ in
     };
 
     networking.firewall.extraPackages = mkOption {
+      type = types.listOf types.package;
       default = [ ];
-      example = [ pkgs.ipset ];
+      example = literalExample "[ pkgs.ipset ]";
       description =
         ''
           Additional packages to be included in the environment of the system