about summary refs log tree commit diff
path: root/nixos/modules/services/networking/dnscrypt-proxy.nix
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2016-08-01 12:55:42 +0200
committerJoachim Fasting <joachifm@fastmail.fm>2016-08-01 12:55:42 +0200
commitc91d07b6689c9f7bd90622a0d31530005c02256d (patch)
treefd176e61339fecee37dfddc5144c0c17ee6c929b /nixos/modules/services/networking/dnscrypt-proxy.nix
parent76f2e827a7b65bb486edb16a2210fa8cc4c457bf (diff)
downloadnixlib-c91d07b6689c9f7bd90622a0d31530005c02256d.tar
nixlib-c91d07b6689c9f7bd90622a0d31530005c02256d.tar.gz
nixlib-c91d07b6689c9f7bd90622a0d31530005c02256d.tar.bz2
nixlib-c91d07b6689c9f7bd90622a0d31530005c02256d.tar.lz
nixlib-c91d07b6689c9f7bd90622a0d31530005c02256d.tar.xz
nixlib-c91d07b6689c9f7bd90622a0d31530005c02256d.tar.zst
nixlib-c91d07b6689c9f7bd90622a0d31530005c02256d.zip
dnscrypt-proxy module: types.string should be types.str
Diffstat (limited to 'nixos/modules/services/networking/dnscrypt-proxy.nix')
-rw-r--r--nixos/modules/services/networking/dnscrypt-proxy.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/networking/dnscrypt-proxy.nix b/nixos/modules/services/networking/dnscrypt-proxy.nix
index 227e38acc4a6..984219676cdd 100644
--- a/nixos/modules/services/networking/dnscrypt-proxy.nix
+++ b/nixos/modules/services/networking/dnscrypt-proxy.nix
@@ -55,7 +55,7 @@ in
       ''; };
       localAddress = mkOption {
         default = "127.0.0.1";
-        type = types.string;
+        type = types.str;
         description = ''
           Listen for DNS queries to relay on this address. The only reason to
           change this from its default value is to proxy queries on behalf
@@ -74,7 +74,7 @@ in
       };
       resolverName = mkOption {
         default = "dnscrypt.eu-nl";
-        type = types.nullOr types.string;
+        type = types.nullOr types.str;
         description = ''
           The name of the upstream DNSCrypt resolver to use, taken from the
           list named in the <literal>resolverList</literal> option.