about summary refs log tree commit diff
path: root/nixos/modules/services/networking/dhcpcd.nix
diff options
context:
space:
mode:
authorrnhmjoj <rnhmjoj@inventati.org>2017-12-03 05:13:14 +0100
committerrnhmjoj <rnhmjoj@inventati.org>2018-02-17 14:01:24 +0100
commitc1bed05e341756f7fdfa73035c7f1e078e49be3d (patch)
tree462f47865c4ff0949484d0aaa2e3845d0eb2ddc7 /nixos/modules/services/networking/dhcpcd.nix
parentf41111c4da9a7eb5cade95d945eec7576757d27d (diff)
downloadnixlib-c1bed05e341756f7fdfa73035c7f1e078e49be3d.tar
nixlib-c1bed05e341756f7fdfa73035c7f1e078e49be3d.tar.gz
nixlib-c1bed05e341756f7fdfa73035c7f1e078e49be3d.tar.bz2
nixlib-c1bed05e341756f7fdfa73035c7f1e078e49be3d.tar.lz
nixlib-c1bed05e341756f7fdfa73035c7f1e078e49be3d.tar.xz
nixlib-c1bed05e341756f7fdfa73035c7f1e078e49be3d.tar.zst
nixlib-c1bed05e341756f7fdfa73035c7f1e078e49be3d.zip
nixos/networking-interfaces: rename IP addresses/routes options
Diffstat (limited to 'nixos/modules/services/networking/dhcpcd.nix')
-rw-r--r--nixos/modules/services/networking/dhcpcd.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/networking/dhcpcd.nix b/nixos/modules/services/networking/dhcpcd.nix
index d283c7624335..d10b72ecf058 100644
--- a/nixos/modules/services/networking/dhcpcd.nix
+++ b/nixos/modules/services/networking/dhcpcd.nix
@@ -16,7 +16,7 @@ let
   # Don't start dhcpcd on explicitly configured interfaces or on
   # interfaces that are part of a bridge, bond or sit device.
   ignoredInterfaces =
-    map (i: i.name) (filter (i: if i.useDHCP != null then !i.useDHCP else i.ip4 != [ ] || i.ipAddress != null) interfaces)
+    map (i: i.name) (filter (i: if i.useDHCP != null then !i.useDHCP else i.ipv4.addresses != [ ]) interfaces)
     ++ mapAttrsToList (i: _: i) config.networking.sits
     ++ concatLists (attrValues (mapAttrs (n: v: v.interfaces) config.networking.bridges))
     ++ concatLists (attrValues (mapAttrs (n: v: v.interfaces) config.networking.vswitches))