about summary refs log tree commit diff
path: root/nixos/modules/services/networking/connman.nix
diff options
context:
space:
mode:
authorMichele Guerini Rocco <rnhmjoj@users.noreply.github.com>2016-09-25 08:02:29 +0200
committerFranz Pletz <fpletz@fnordicwalking.de>2016-09-25 08:02:29 +0200
commitec8d5945cef0df538c071c75233be3af168f4cff (patch)
tree962c9184ced61c6b8c72b2d2f7666f8920e20e2d /nixos/modules/services/networking/connman.nix
parent68a38d6c0fac363ef24e72933e0a147599048502 (diff)
downloadnixlib-ec8d5945cef0df538c071c75233be3af168f4cff.tar
nixlib-ec8d5945cef0df538c071c75233be3af168f4cff.tar.gz
nixlib-ec8d5945cef0df538c071c75233be3af168f4cff.tar.bz2
nixlib-ec8d5945cef0df538c071c75233be3af168f4cff.tar.lz
nixlib-ec8d5945cef0df538c071c75233be3af168f4cff.tar.xz
nixlib-ec8d5945cef0df538c071c75233be3af168f4cff.tar.zst
nixlib-ec8d5945cef0df538c071c75233be3af168f4cff.zip
connman: disable connman-vpn by default (#18323)
Diffstat (limited to 'nixos/modules/services/networking/connman.nix')
-rw-r--r--nixos/modules/services/networking/connman.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/nixos/modules/services/networking/connman.nix b/nixos/modules/services/networking/connman.nix
index 3fecfbb13a04..d0683b877801 100644
--- a/nixos/modules/services/networking/connman.nix
+++ b/nixos/modules/services/networking/connman.nix
@@ -27,6 +27,14 @@ in {
         '';
       };
 
+      enableVPN = mkOption {
+        type = types.bool;
+        default = true;
+        description = ''
+          Whether to enable ConnMan VPN service.
+        '';
+      };
+
       extraConfig = mkOption {
         type = types.lines;
         default = ''
@@ -78,7 +86,7 @@ in {
       };
     };
 
-    systemd.services."connman-vpn" = {
+    systemd.services."connman-vpn" = mkIf cfg.enableVPN {
       description = "ConnMan VPN service";
       wantedBy = [ "multi-user.target" ];
       after = [ "syslog.target" ];
@@ -91,7 +99,7 @@ in {
       };
     };
 
-    systemd.services."net-connman-vpn" = {
+    systemd.services."net-connman-vpn" = mkIf cfg.enableVPN {
       description = "D-BUS Service";
       serviceConfig = {
         Name = "net.connman.vpn";