about summary refs log tree commit diff
path: root/nixos/modules/services/network-filesystems/davfs2.nix
diff options
context:
space:
mode:
authorSilvan Mosberger <infinisil@icloud.com>2019-08-08 22:48:27 +0200
committerSilvan Mosberger <infinisil@icloud.com>2019-08-31 18:19:00 +0200
commit478e7184f88db1364cc75107036f7c4decc0cc41 (patch)
tree5ff3d3a18e3aef9af4333c392a94751333754270 /nixos/modules/services/network-filesystems/davfs2.nix
parent69d58ee24506e2b3b5aff347ae3b0791110340ec (diff)
downloadnixlib-478e7184f88db1364cc75107036f7c4decc0cc41.tar
nixlib-478e7184f88db1364cc75107036f7c4decc0cc41.tar.gz
nixlib-478e7184f88db1364cc75107036f7c4decc0cc41.tar.bz2
nixlib-478e7184f88db1364cc75107036f7c4decc0cc41.tar.lz
nixlib-478e7184f88db1364cc75107036f7c4decc0cc41.tar.xz
nixlib-478e7184f88db1364cc75107036f7c4decc0cc41.tar.zst
nixlib-478e7184f88db1364cc75107036f7c4decc0cc41.zip
nixos/modules: Remove all usages of types.string
And replace them with a more appropriate type

Also fix up some minor module problems along the way
Diffstat (limited to 'nixos/modules/services/network-filesystems/davfs2.nix')
-rw-r--r--nixos/modules/services/network-filesystems/davfs2.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/network-filesystems/davfs2.nix b/nixos/modules/services/network-filesystems/davfs2.nix
index c16e12378d75..100d458d536c 100644
--- a/nixos/modules/services/network-filesystems/davfs2.nix
+++ b/nixos/modules/services/network-filesystems/davfs2.nix
@@ -21,7 +21,7 @@ in
     };
 
     davUser = mkOption {
-      type = types.string;
+      type = types.str;
       default = "davfs2";
       description = ''
         When invoked by root the mount.davfs daemon will run as this user.
@@ -30,7 +30,7 @@ in
     };
 
     davGroup = mkOption {
-      type = types.string;
+      type = types.str;
       default = "davfs2";
       description = ''
         The group of the running mount.davfs daemon. Ordinary users must be