about summary refs log tree commit diff
path: root/nixos/modules/services/network-filesystems/ceph.nix
diff options
context:
space:
mode:
authorrnhmjoj <rnhmjoj@inventati.org>2019-09-14 19:51:29 +0200
committerworldofpeace <worldofpeace@protonmail.ch>2020-01-06 10:39:18 -0500
commit1d61efb7f177f7b70c467ab4940fde0a3481d4dc (patch)
tree860cce85acd87bc07aa2d11f4feac5d0df48a5c0 /nixos/modules/services/network-filesystems/ceph.nix
parent6bd13ccd8e7fd1f241eb655f7112df1ed2889a3a (diff)
downloadnixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.gz
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.bz2
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.lz
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.xz
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.zst
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.zip
treewide: use attrs instead of list for types.loaOf options
Diffstat (limited to 'nixos/modules/services/network-filesystems/ceph.nix')
-rw-r--r--nixos/modules/services/network-filesystems/ceph.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/nixos/modules/services/network-filesystems/ceph.nix b/nixos/modules/services/network-filesystems/ceph.nix
index 543a7b25d5d6..d17959a6a305 100644
--- a/nixos/modules/services/network-filesystems/ceph.nix
+++ b/nixos/modules/services/network-filesystems/ceph.nix
@@ -371,15 +371,14 @@ in
       in
         generators.toINI {} totalConfig;
 
-    users.users = singleton {
-      name = "ceph";
+    users.users.ceph = {
       uid = config.ids.uids.ceph;
       description = "Ceph daemon user";
       group = "ceph";
       extraGroups = [ "disk" ];
     };
-    users.groups = singleton {
-      name = "ceph";
+
+    users.groups.ceph = {
       gid = config.ids.gids.ceph;
     };