about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/tuptime.nix
diff options
context:
space:
mode:
authorEvils <evils.devils@protonmail.com>2022-08-16 09:55:31 +0200
committerEvils <evils.devils@protonmail.com>2022-08-16 10:03:12 +0200
commit3895a5baa211d1e4a597be5fc957d078d326f8af (patch)
tree475c13268a8c20c032c1ec604120bbba8f11623b /nixos/modules/services/monitoring/tuptime.nix
parent6512b21eabb4d52e87ea2edcf31a288e67b2e4f8 (diff)
downloadnixlib-3895a5baa211d1e4a597be5fc957d078d326f8af.tar
nixlib-3895a5baa211d1e4a597be5fc957d078d326f8af.tar.gz
nixlib-3895a5baa211d1e4a597be5fc957d078d326f8af.tar.bz2
nixlib-3895a5baa211d1e4a597be5fc957d078d326f8af.tar.lz
nixlib-3895a5baa211d1e4a597be5fc957d078d326f8af.tar.xz
nixlib-3895a5baa211d1e4a597be5fc957d078d326f8af.tar.zst
nixlib-3895a5baa211d1e4a597be5fc957d078d326f8af.zip
tuptime: 5.1.0 -> 5.2.0
add meta.changelog

and update module to upstream wording
Diffstat (limited to 'nixos/modules/services/monitoring/tuptime.nix')
-rw-r--r--nixos/modules/services/monitoring/tuptime.nix13
1 files changed, 6 insertions, 7 deletions
diff --git a/nixos/modules/services/monitoring/tuptime.nix b/nixos/modules/services/monitoring/tuptime.nix
index ffe24c0ef0be..770fbee2a844 100644
--- a/nixos/modules/services/monitoring/tuptime.nix
+++ b/nixos/modules/services/monitoring/tuptime.nix
@@ -45,7 +45,7 @@ in {
       services = {
 
         tuptime = {
-          description = "the total uptime service";
+          description = "The total uptime service";
           documentation = [ "man:tuptime(1)" ];
           after = [ "time-sync.target" ];
           wantedBy = [ "multi-user.target" ];
@@ -59,10 +59,9 @@ in {
           };
         };
 
-        tuptime-oneshot = mkIf cfg.timer.enable {
-          description = "the tuptime scheduled execution unit";
+        tuptime-sync = mkIf cfg.timer.enable {
+          description = "Tuptime scheduled sync service";
           serviceConfig = {
-            StateDirectory = "tuptime";
             Type = "oneshot";
             User = "_tuptime";
             ExecStart = "${pkgs.tuptime}/bin/tuptime -x";
@@ -70,8 +69,8 @@ in {
         };
       };
 
-      timers.tuptime = mkIf cfg.timer.enable {
-        description = "the tuptime scheduled execution timer";
+      timers.tuptime-sync = mkIf cfg.timer.enable {
+        description = "Tuptime scheduled sync timer";
         # this timer should be started if the service is started
         # even if the timer was previously stopped
         wantedBy = [ "tuptime.service" "timers.target" ];
@@ -80,7 +79,7 @@ in {
         timerConfig = {
           OnBootSec = "1min";
           OnCalendar = cfg.timer.period;
-          Unit = "tuptime-oneshot.service";
+          Unit = "tuptime-sync.service";
         };
       };
     };