about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/thanos.nix
diff options
context:
space:
mode:
authorRobert Hensing <robert@roberthensing.nl>2021-08-15 17:12:23 +0200
committerRobert Hensing <robert@roberthensing.nl>2021-08-15 17:36:41 +0200
commitfbafeb7ad5dd6196fcc5d84264e1706653a62f81 (patch)
tree5e80c4048b4206232b22dc2a8e893e6575ba93d8 /nixos/modules/services/monitoring/thanos.nix
parent1359293549af4f8ca536716d0432f3cdd0afe0c6 (diff)
downloadnixlib-fbafeb7ad5dd6196fcc5d84264e1706653a62f81.tar
nixlib-fbafeb7ad5dd6196fcc5d84264e1706653a62f81.tar.gz
nixlib-fbafeb7ad5dd6196fcc5d84264e1706653a62f81.tar.bz2
nixlib-fbafeb7ad5dd6196fcc5d84264e1706653a62f81.tar.lz
nixlib-fbafeb7ad5dd6196fcc5d84264e1706653a62f81.tar.xz
nixlib-fbafeb7ad5dd6196fcc5d84264e1706653a62f81.tar.zst
nixlib-fbafeb7ad5dd6196fcc5d84264e1706653a62f81.zip
treewide: runCommandNoCC -> runCommand
This has been synonymous for ~5y.
Diffstat (limited to 'nixos/modules/services/monitoring/thanos.nix')
-rw-r--r--nixos/modules/services/monitoring/thanos.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/monitoring/thanos.nix b/nixos/modules/services/monitoring/thanos.nix
index 474ea4b25054..96addf392bd7 100644
--- a/nixos/modules/services/monitoring/thanos.nix
+++ b/nixos/modules/services/monitoring/thanos.nix
@@ -63,7 +63,7 @@ let
     };
   };
 
-  toYAML = name: attrs: pkgs.runCommandNoCC name {
+  toYAML = name: attrs: pkgs.runCommand name {
     preferLocalBuild = true;
     json = builtins.toFile "${name}.json" (builtins.toJSON attrs);
     nativeBuildInputs = [ pkgs.remarshal ];