about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/statsd.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 11:02:04 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 14:57:42 +0100
commit862e3dd977cdd853c3ab3202ab1b73561f8a3ea1 (patch)
tree43e95414e328ac92383bccf41219c30fa9729473 /nixos/modules/services/monitoring/statsd.nix
parent162b874469935923dec02cc9a6b5f58b1c8267a8 (diff)
downloadnixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.gz
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.bz2
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.lz
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.xz
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.zst
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.zip
Substitute "types.uniq types.string" -> "types.str"
Diffstat (limited to 'nixos/modules/services/monitoring/statsd.nix')
-rw-r--r--nixos/modules/services/monitoring/statsd.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/modules/services/monitoring/statsd.nix b/nixos/modules/services/monitoring/statsd.nix
index 120c8860d571..979debefdd9f 100644
--- a/nixos/modules/services/monitoring/statsd.nix
+++ b/nixos/modules/services/monitoring/statsd.nix
@@ -36,7 +36,7 @@ in
     host = mkOption {
       description = "Address that statsd listens on over UDP";
       default = "127.0.0.1";
-      type = types.uniq types.string;
+      type = types.str;
     };
 
     port = mkOption {
@@ -48,7 +48,7 @@ in
     mgmt_address = mkOption {
       description = "Address to run managment TCP interface on";
       default = "127.0.0.1";
-      type = types.uniq types.string;
+      type = types.str;
     };
 
     mgmt_port = mkOption {
@@ -65,7 +65,7 @@ in
     graphiteHost = mkOption {
       description = "Hostname or IP of Graphite server";
       default = "127.0.0.1";
-      type = types.uniq types.string;
+      type = types.str;
     };
 
     graphitePort = mkOption {
@@ -77,7 +77,7 @@ in
     extraConfig = mkOption {
       default = "";
       description = "Extra configuration options for statsd";
-      type = types.uniq types.string;
+      type = types.str;
     };
 
   };