about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/prometheus/default.nix
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@Yahoo.com>2017-04-17 16:48:10 -0400
committerJohn Ericson <Ericson2314@Yahoo.com>2017-04-17 17:04:04 -0400
commit85aa5005af530fef199cc41148e374e54d70e01e (patch)
tree296a184cc5e710e197f45a91babb107bf8509eae /nixos/modules/services/monitoring/prometheus/default.nix
parentf3055a3c508b6ff3e926ece201887467dc2b5d73 (diff)
downloadnixlib-85aa5005af530fef199cc41148e374e54d70e01e.tar
nixlib-85aa5005af530fef199cc41148e374e54d70e01e.tar.gz
nixlib-85aa5005af530fef199cc41148e374e54d70e01e.tar.bz2
nixlib-85aa5005af530fef199cc41148e374e54d70e01e.tar.lz
nixlib-85aa5005af530fef199cc41148e374e54d70e01e.tar.xz
nixlib-85aa5005af530fef199cc41148e374e54d70e01e.tar.zst
nixlib-85aa5005af530fef199cc41148e374e54d70e01e.zip
Introduce `mapNullable` into lib and use it in a few places
Also simply some configure flag logic my grep also alerted me too.
Diffstat (limited to 'nixos/modules/services/monitoring/prometheus/default.nix')
-rw-r--r--nixos/modules/services/monitoring/prometheus/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/monitoring/prometheus/default.nix b/nixos/modules/services/monitoring/prometheus/default.nix
index cf9deccbffe2..5c4a48a7db4b 100644
--- a/nixos/modules/services/monitoring/prometheus/default.nix
+++ b/nixos/modules/services/monitoring/prometheus/default.nix
@@ -134,7 +134,7 @@ let
           };
         });
         default = null;
-        apply = x: if x == null then null else _filter x;
+        apply = x: mapNullable _filter x;
         description = ''
           Optional http login credentials for metrics scraping.
         '';