about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/prometheus/default.nix
diff options
context:
space:
mode:
authorTravis Athougies <travis@athougies.net>2020-04-28 10:22:03 -0700
committerGitHub <noreply@github.com>2020-04-28 10:22:03 -0700
commit8389fb8f169bf770cdadf856030bf698ff0baeec (patch)
treeaa44a6dfde9e2355c2f0e70d1c1b369ea93ca94c /nixos/modules/services/monitoring/prometheus/default.nix
parente257a92472e63c06662c69bd4e2b1b50db37938a (diff)
downloadnixlib-8389fb8f169bf770cdadf856030bf698ff0baeec.tar
nixlib-8389fb8f169bf770cdadf856030bf698ff0baeec.tar.gz
nixlib-8389fb8f169bf770cdadf856030bf698ff0baeec.tar.bz2
nixlib-8389fb8f169bf770cdadf856030bf698ff0baeec.tar.lz
nixlib-8389fb8f169bf770cdadf856030bf698ff0baeec.tar.xz
nixlib-8389fb8f169bf770cdadf856030bf698ff0baeec.tar.zst
nixlib-8389fb8f169bf770cdadf856030bf698ff0baeec.zip
[nixos/prometheus] promTypes.filter.value -> promTypes.filter.values
The new configuration name for this is plural. Currently, attempting to enable ec2 SD results in a `promtool check config` error
Diffstat (limited to 'nixos/modules/services/monitoring/prometheus/default.nix')
-rw-r--r--nixos/modules/services/monitoring/prometheus/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/monitoring/prometheus/default.nix b/nixos/modules/services/monitoring/prometheus/default.nix
index 84a72afac2f7..76b1f755447b 100644
--- a/nixos/modules/services/monitoring/prometheus/default.nix
+++ b/nixos/modules/services/monitoring/prometheus/default.nix
@@ -307,7 +307,7 @@ let
         '';
       };
 
-      value = mkOption {
+      values = mkOption {
         type = types.listOf types.str;
         default = [];
         description = ''