about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/prometheus/default.nix
diff options
context:
space:
mode:
authorBas van Dijk <bas@van.dijk.ch>2021-11-07 19:04:24 +0000
committerBas van Dijk <bas@van.dijk.ch>2021-11-07 19:04:24 +0000
commit7f7780daa55e8f2de87acc7563078a3db85e7feb (patch)
tree18b41b1faf524b12be96481f30a9252c9877189f /nixos/modules/services/monitoring/prometheus/default.nix
parent0e4abb0df773cf7d9ff8dc2792358c0b8508d5eb (diff)
downloadnixlib-7f7780daa55e8f2de87acc7563078a3db85e7feb.tar
nixlib-7f7780daa55e8f2de87acc7563078a3db85e7feb.tar.gz
nixlib-7f7780daa55e8f2de87acc7563078a3db85e7feb.tar.bz2
nixlib-7f7780daa55e8f2de87acc7563078a3db85e7feb.tar.lz
nixlib-7f7780daa55e8f2de87acc7563078a3db85e7feb.tar.xz
nixlib-7f7780daa55e8f2de87acc7563078a3db85e7feb.tar.zst
nixlib-7f7780daa55e8f2de87acc7563078a3db85e7feb.zip
nixos/prometheus: throw a helpful error when services.prometheus.environmentFile is defined
Diffstat (limited to 'nixos/modules/services/monitoring/prometheus/default.nix')
-rw-r--r--nixos/modules/services/monitoring/prometheus/default.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/modules/services/monitoring/prometheus/default.nix b/nixos/modules/services/monitoring/prometheus/default.nix
index a35bf145308d..f20b8dde1abd 100644
--- a/nixos/modules/services/monitoring/prometheus/default.nix
+++ b/nixos/modules/services/monitoring/prometheus/default.nix
@@ -1554,6 +1554,8 @@ in
 
   imports = [
     (mkRenamedOptionModule [ "services" "prometheus2" ] [ "services" "prometheus" ])
+    (mkRemovedOptionModule [ "services" "prometheus" "environmentFile" ]
+      "It has been removed since it was causing issues (https://github.com/NixOS/nixpkgs/issues/126083) and Prometheus now has native support for secret files, i.e. `basic_auth.password_file` and `authorization.credentials_file`.")
   ];
 
   options.services.prometheus = {