about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/prometheus/default.nix
diff options
context:
space:
mode:
authorSandro Jäckel <sandro.jaeckel@gmail.com>2022-01-08 20:42:32 +0100
committerSandro Jäckel <sandro.jaeckel@gmail.com>2022-01-08 22:56:51 +0100
commit39ce4ddd85bad02d48c7c0588d50ee03af6a8ef9 (patch)
tree726f71df6c9e680036944bcb808dbb7803fb84fd /nixos/modules/services/monitoring/prometheus/default.nix
parent41d2ab408517d45f1edeb45649045a0e3ea109bb (diff)
downloadnixlib-39ce4ddd85bad02d48c7c0588d50ee03af6a8ef9.tar
nixlib-39ce4ddd85bad02d48c7c0588d50ee03af6a8ef9.tar.gz
nixlib-39ce4ddd85bad02d48c7c0588d50ee03af6a8ef9.tar.bz2
nixlib-39ce4ddd85bad02d48c7c0588d50ee03af6a8ef9.tar.lz
nixlib-39ce4ddd85bad02d48c7c0588d50ee03af6a8ef9.tar.xz
nixlib-39ce4ddd85bad02d48c7c0588d50ee03af6a8ef9.tar.zst
nixlib-39ce4ddd85bad02d48c7c0588d50ee03af6a8ef9.zip
nixos/prometheus: fix usage of bearer_token
Diffstat (limited to 'nixos/modules/services/monitoring/prometheus/default.nix')
-rw-r--r--nixos/modules/services/monitoring/prometheus/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/monitoring/prometheus/default.nix b/nixos/modules/services/monitoring/prometheus/default.nix
index b36b5fd06504..f563861b61c0 100644
--- a/nixos/modules/services/monitoring/prometheus/default.nix
+++ b/nixos/modules/services/monitoring/prometheus/default.nix
@@ -252,8 +252,8 @@ let
   promTypes.scrape_config = types.submodule {
     options = {
       authorization = mkOption {
-        type = types.attrs;
-        default = {};
+        type = types.nullOr types.attrs;
+        default = null;
         description = ''
           Sets the `Authorization` header on every scrape request with the configured credentials.
         '';