about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/osquery.nix
diff options
context:
space:
mode:
authorAntoine Eiche <lewo@gandi.net>2023-07-26 17:22:22 +0200
committerAntoine Eiche <lewo@gandi.net>2023-07-26 17:22:22 +0200
commit8af1d49858d2ccf504bc33d066ba047795d43093 (patch)
tree0c0e153e7e38a249ec0a6c2c5cbbdff464903e09 /nixos/modules/services/monitoring/osquery.nix
parent8dff9f64ecb309e362b59dc099c090ae4f633481 (diff)
downloadnixlib-8af1d49858d2ccf504bc33d066ba047795d43093.tar
nixlib-8af1d49858d2ccf504bc33d066ba047795d43093.tar.gz
nixlib-8af1d49858d2ccf504bc33d066ba047795d43093.tar.bz2
nixlib-8af1d49858d2ccf504bc33d066ba047795d43093.tar.lz
nixlib-8af1d49858d2ccf504bc33d066ba047795d43093.tar.xz
nixlib-8af1d49858d2ccf504bc33d066ba047795d43093.tar.zst
nixlib-8af1d49858d2ccf504bc33d066ba047795d43093.zip
nixos/osquery: do not use the local database for osqueryi
Because the local database is used by the osquery deamon, running
osqueri fails with:

    IO error: While lock file: /var/lib/osquery/osquery.db/LOCK:    Resource temporarily unavailable
Diffstat (limited to 'nixos/modules/services/monitoring/osquery.nix')
-rw-r--r--nixos/modules/services/monitoring/osquery.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/monitoring/osquery.nix b/nixos/modules/services/monitoring/osquery.nix
index 98524d0c700c..4f6c2557a641 100644
--- a/nixos/modules/services/monitoring/osquery.nix
+++ b/nixos/modules/services/monitoring/osquery.nix
@@ -21,7 +21,7 @@ let
   osqueryi = pkgs.runCommand "osqueryi" { nativeBuildInputs = [ pkgs.makeWrapper ]; } ''
     mkdir -p $out/bin
     makeWrapper ${pkgs.osquery}/bin/osqueryi $out/bin/osqueryi \
-      --add-flags "--flagfile ${flagfile}"
+      --add-flags "--flagfile ${flagfile} --disable-database"
   '';
 in
 {