about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/heapster.nix
diff options
context:
space:
mode:
authorDaniel Nagy <danielnagy@posteo.de>2022-11-09 22:45:00 +0100
committerDaniel Nagy <danielnagy@posteo.de>2022-11-10 09:30:00 +0100
commitb4674b39c1928f05118ea0c1c4fb8ab66190edd6 (patch)
tree4d89384b89b51100ccf9ca3c244d62bd3b15892f /nixos/modules/services/monitoring/heapster.nix
parent095269c8622e878eaaac117cc6b63dd1a4970a68 (diff)
downloadnixlib-b4674b39c1928f05118ea0c1c4fb8ab66190edd6.tar
nixlib-b4674b39c1928f05118ea0c1c4fb8ab66190edd6.tar.gz
nixlib-b4674b39c1928f05118ea0c1c4fb8ab66190edd6.tar.bz2
nixlib-b4674b39c1928f05118ea0c1c4fb8ab66190edd6.tar.lz
nixlib-b4674b39c1928f05118ea0c1c4fb8ab66190edd6.tar.xz
nixlib-b4674b39c1928f05118ea0c1c4fb8ab66190edd6.tar.zst
nixlib-b4674b39c1928f05118ea0c1c4fb8ab66190edd6.zip
treewide: use `mkEnableOption` in nixos modules
Diffstat (limited to 'nixos/modules/services/monitoring/heapster.nix')
-rw-r--r--nixos/modules/services/monitoring/heapster.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/nixos/modules/services/monitoring/heapster.nix b/nixos/modules/services/monitoring/heapster.nix
index 2f2467477ae2..fc63276b62f7 100644
--- a/nixos/modules/services/monitoring/heapster.nix
+++ b/nixos/modules/services/monitoring/heapster.nix
@@ -6,11 +6,7 @@ let
   cfg = config.services.heapster;
 in {
   options.services.heapster = {
-    enable = mkOption {
-      description = lib.mdDoc "Whether to enable heapster monitoring";
-      default = false;
-      type = types.bool;
-    };
+    enable = mkEnableOption (lib.mdDoc "Heapster monitoring");
 
     source = mkOption {
       description = lib.mdDoc "Heapster metric source";