about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/datadog-agent.nix
diff options
context:
space:
mode:
authorAlexander Flurie <alex.flurie@agilityrobotics.com>2023-07-17 10:34:50 -0400
committerAlexander Flurie <alex.flurie@agilityrobotics.com>2023-07-17 10:34:50 -0400
commitc2861bcbdf4a2a3e92b39df64498381c0e43779c (patch)
tree83b845d63a9e4c8cbfac40abaaae301e65667801 /nixos/modules/services/monitoring/datadog-agent.nix
parentaae530ab37c3885d419c075ead0c18fc87852e95 (diff)
downloadnixlib-c2861bcbdf4a2a3e92b39df64498381c0e43779c.tar
nixlib-c2861bcbdf4a2a3e92b39df64498381c0e43779c.tar.gz
nixlib-c2861bcbdf4a2a3e92b39df64498381c0e43779c.tar.bz2
nixlib-c2861bcbdf4a2a3e92b39df64498381c0e43779c.tar.lz
nixlib-c2861bcbdf4a2a3e92b39df64498381c0e43779c.tar.xz
nixlib-c2861bcbdf4a2a3e92b39df64498381c0e43779c.tar.zst
nixlib-c2861bcbdf4a2a3e92b39df64498381c0e43779c.zip
add separate configurable datadog process agent
Diffstat (limited to 'nixos/modules/services/monitoring/datadog-agent.nix')
-rw-r--r--nixos/modules/services/monitoring/datadog-agent.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/nixos/modules/services/monitoring/datadog-agent.nix b/nixos/modules/services/monitoring/datadog-agent.nix
index 58a0faed962c..def8097a2c44 100644
--- a/nixos/modules/services/monitoring/datadog-agent.nix
+++ b/nixos/modules/services/monitoring/datadog-agent.nix
@@ -153,6 +153,18 @@ in {
       type = types.bool;
     };
 
+    processAgentPackage = mkOption {
+      default = pkgs.datadog-process-agent;
+      defaultText = literalExpression "pkgs.datadog-process-agent";
+      description = lib.mdDoc ''
+        Which DataDog v7 agent package to use. Note that the provided
+        package is expected to have an overridable `pythonPackages`-attribute
+        which configures the Python environment with the Datadog
+        checks.
+      '';
+      type = types.package;
+    };
+    
     enableTraceAgent = mkOption {
       description = lib.mdDoc ''
         Whether to enable the trace agent.
@@ -270,7 +282,7 @@ in {
         path = [ ];
         script = ''
           export DD_API_KEY=$(head -n 1 ${cfg.apiKeyFile})
-          ${pkgs.datadog-process-agent}/bin/process-agent --config /etc/datadog-agent/datadog.yaml
+          ${cfg.processAgentPackage}/bin/process-agent --config /etc/datadog-agent/datadog.yaml
         '';
       });