about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/collectd.nix
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2016-02-15 03:34:49 +0100
committerFranz Pletz <fpletz@fnordicwalking.de>2016-02-18 03:44:55 +0100
commited979124cad7596de539188e86664b3784c363ca (patch)
tree173acea0db5674756a392ed3c16f9012261690d2 /nixos/modules/services/monitoring/collectd.nix
parenteff9726d54ee42b4a58d5c076fe4a5845844ecef (diff)
downloadnixlib-ed979124cad7596de539188e86664b3784c363ca.tar
nixlib-ed979124cad7596de539188e86664b3784c363ca.tar.gz
nixlib-ed979124cad7596de539188e86664b3784c363ca.tar.bz2
nixlib-ed979124cad7596de539188e86664b3784c363ca.tar.lz
nixlib-ed979124cad7596de539188e86664b3784c363ca.tar.xz
nixlib-ed979124cad7596de539188e86664b3784c363ca.tar.zst
nixlib-ed979124cad7596de539188e86664b3784c363ca.zip
collectd service: Add option package
Diffstat (limited to 'nixos/modules/services/monitoring/collectd.nix')
-rw-r--r--nixos/modules/services/monitoring/collectd.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/nixos/modules/services/monitoring/collectd.nix b/nixos/modules/services/monitoring/collectd.nix
index 717c2c481683..414831ae9d41 100644
--- a/nixos/modules/services/monitoring/collectd.nix
+++ b/nixos/modules/services/monitoring/collectd.nix
@@ -34,6 +34,14 @@ in {
       type = bool;
     };
 
+    package = mkOption {
+      default = pkgs.collectd;
+      description = ''
+        Which collectd package to use.
+      '';
+      type = package;
+    };
+
     user = mkOption {
       default = "collectd";
       description = ''