about summary refs log tree commit diff
path: root/nixos/modules/services/misc/zoneminder.nix
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2022-08-29 21:48:56 +0200
committerpennae <github@quasiparticle.net>2022-08-31 16:32:14 +0200
commit1013069f52123135cc1d96b2b7d77606a22d3b33 (patch)
treef985c37e7b051d769aefbaf179bbd5bcbb7e507d /nixos/modules/services/misc/zoneminder.nix
parent7d102d113abd84dd29bed71cd589f1c68a7f7f3d (diff)
downloadnixlib-1013069f52123135cc1d96b2b7d77606a22d3b33.tar
nixlib-1013069f52123135cc1d96b2b7d77606a22d3b33.tar.gz
nixlib-1013069f52123135cc1d96b2b7d77606a22d3b33.tar.bz2
nixlib-1013069f52123135cc1d96b2b7d77606a22d3b33.tar.lz
nixlib-1013069f52123135cc1d96b2b7d77606a22d3b33.tar.xz
nixlib-1013069f52123135cc1d96b2b7d77606a22d3b33.tar.zst
nixlib-1013069f52123135cc1d96b2b7d77606a22d3b33.zip
nixos/*: convert more partially-md option descriptions
this mostly means marking options that use markdown already
appropriately and making a few adjustments so they still render
correctly. notable for nftables we have to transform the md links
because the manpage would not render them correctly otherwise.
Diffstat (limited to 'nixos/modules/services/misc/zoneminder.nix')
-rw-r--r--nixos/modules/services/misc/zoneminder.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/misc/zoneminder.nix b/nixos/modules/services/misc/zoneminder.nix
index fa0e06a01480..e031fab5970b 100644
--- a/nixos/modules/services/misc/zoneminder.nix
+++ b/nixos/modules/services/misc/zoneminder.nix
@@ -66,7 +66,7 @@ let
 in {
   options = {
     services.zoneminder = with lib; {
-      enable = lib.mkEnableOption ''
+      enable = lib.mkEnableOption (lib.mdDoc ''
         ZoneMinder
 
         If you intend to run the database locally, you should set
@@ -75,7 +75,7 @@ in {
         and database user as well as populate the database yourself.
         Additionally, you will need to run `zmupdate.pl` yourself when
         upgrading to a newer version.
-      '';
+      '');
 
       webserver = mkOption {
         type = types.enum [ "nginx" "none" ];