about summary refs log tree commit diff
path: root/nixos/modules/services/misc/rogue.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 17:37:45 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 18:47:43 +0100
commit408b8b5725c3e6fff75aef772da248d3e95ff414 (patch)
tree692e3b61dbbff85cc97e3becf13a1376dea04a92 /nixos/modules/services/misc/rogue.nix
parentd882e1966251880240599d3c1b31e060661506ee (diff)
downloadnixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.gz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.bz2
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.lz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.xz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.zst
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.zip
Add lots of missing option types
Diffstat (limited to 'nixos/modules/services/misc/rogue.nix')
-rw-r--r--nixos/modules/services/misc/rogue.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/modules/services/misc/rogue.nix b/nixos/modules/services/misc/rogue.nix
index 94fa88507504..de25cc0fb982 100644
--- a/nixos/modules/services/misc/rogue.nix
+++ b/nixos/modules/services/misc/rogue.nix
@@ -17,6 +17,7 @@ in
   options = {
 
     services.rogue.enable = mkOption {
+      type = types.bool;
       default = false;
       description = ''
         Whether to enable the Rogue game on one of the virtual
@@ -25,6 +26,7 @@ in
     };
 
     services.rogue.tty = mkOption {
+      type = types.str;
       default = "tty9";
       description = ''
         Virtual console on which to run Rogue.