about summary refs log tree commit diff
path: root/nixos/modules/services/misc/rippled.nix
diff options
context:
space:
mode:
authorEmery Hemingway <emery@vfemail.net>2014-03-31 22:59:01 -0400
committerEmery Hemingway <emery@vfemail.net>2014-03-31 22:59:01 -0400
commitdef448f127ddc6383f1811de74eb04bf28615018 (patch)
tree3898304642170cab7f40e3c31da839c83a71dfa9 /nixos/modules/services/misc/rippled.nix
parent6c77690b2898aa8a12184ca8f3c113a11c957e50 (diff)
downloadnixlib-def448f127ddc6383f1811de74eb04bf28615018.tar
nixlib-def448f127ddc6383f1811de74eb04bf28615018.tar.gz
nixlib-def448f127ddc6383f1811de74eb04bf28615018.tar.bz2
nixlib-def448f127ddc6383f1811de74eb04bf28615018.tar.lz
nixlib-def448f127ddc6383f1811de74eb04bf28615018.tar.xz
nixlib-def448f127ddc6383f1811de74eb04bf28615018.tar.zst
nixlib-def448f127ddc6383f1811de74eb04bf28615018.zip
rippled: added comment on commented out config options
Diffstat (limited to 'nixos/modules/services/misc/rippled.nix')
-rw-r--r--nixos/modules/services/misc/rippled.nix32
1 files changed, 10 insertions, 22 deletions
diff --git a/nixos/modules/services/misc/rippled.nix b/nixos/modules/services/misc/rippled.nix
index 7d339a48b976..e4d1caa565c8 100644
--- a/nixos/modules/services/misc/rippled.nix
+++ b/nixos/modules/services/misc/rippled.nix
@@ -18,18 +18,6 @@ let
     /var/log/rippled/debug.log
 
   ''
-  /*
-  + optionalString (cfg.ips != null) ''
-    [ips]
-    ${concatStringsSep "\n" cfg.ips}
-
-  ''
-  + optionalString (cfg.ipsFixed != null) ''
-    [ips_fixed]
-    ${concatStringsSep "\n" cfg.ipsFixed}
-
-  ''
-  */
   + optionalString (cfg.peerIp != null) ''
     [peer_ip]
     ${cfg.peerIp}
@@ -57,6 +45,16 @@ in
 	description = "Whether to enable rippled";
       };
 
+      #
+      # Rippled has a simple configuration file layout that is easy to 
+      # build with nix. Many of the options are defined here but are 
+      # commented out until the code to append them to the config above
+      # is written and they are tested.
+      #
+      # If you find a yourself implementing more options, please submit a 
+      # pull request.
+      #
+
       /*
       ips = mkOption {
         default = [ "r.ripple.com 51235" ];
@@ -286,16 +284,6 @@ in
 
   config = mkIf cfg.enable {
 
-    environment = {
-      etc = singleton
-        { source = rippledStateCfgFile;
-	  target = "rippled";
-	};
-	
-	# users can attempt to send RPC commands to the server.
-	systemPackages = [ pkgs.rippled ];
-    };
-
     users.extraUsers = singleton
       { name = "rippled";
         description = "Ripple server user";