about summary refs log tree commit diff
path: root/nixos/modules/services/misc/nixos-manual.nix
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2016-01-13 11:48:11 +0100
committerVladimír Čunát <vcunat@gmail.com>2016-02-03 14:47:14 +0100
commit4fede53c0996938979d2966a69f108782a8c1c12 (patch)
tree6f15d992897ef0ef0b26636c6cb769e4868d86d5 /nixos/modules/services/misc/nixos-manual.nix
parente0feace5cde328a8f7478b2cf762991316d4c07c (diff)
downloadnixlib-4fede53c0996938979d2966a69f108782a8c1c12.tar
nixlib-4fede53c0996938979d2966a69f108782a8c1c12.tar.gz
nixlib-4fede53c0996938979d2966a69f108782a8c1c12.tar.bz2
nixlib-4fede53c0996938979d2966a69f108782a8c1c12.tar.lz
nixlib-4fede53c0996938979d2966a69f108782a8c1c12.tar.xz
nixlib-4fede53c0996938979d2966a69f108782a8c1c12.tar.zst
nixlib-4fede53c0996938979d2966a69f108782a8c1c12.zip
nixos manuals: bring back package references
This reverts most of 89e983786a, as those references are sanitized now.
Fixes #10039, at least most of it.

The `sane` case wasn't fixed, as it calls a *function* in pkgs to get
the default value.
Diffstat (limited to 'nixos/modules/services/misc/nixos-manual.nix')
-rw-r--r--nixos/modules/services/misc/nixos-manual.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/nixos/modules/services/misc/nixos-manual.nix b/nixos/modules/services/misc/nixos-manual.nix
index 8ef1b035ca6f..b586bc84579b 100644
--- a/nixos/modules/services/misc/nixos-manual.nix
+++ b/nixos/modules/services/misc/nixos-manual.nix
@@ -96,6 +96,7 @@ in
 
     services.nixosManual.browser = mkOption {
       type = types.path;
+      default = "${pkgs.w3m-nox}/bin/w3m";
       description = ''
         Browser used to show the manual.
       '';
@@ -133,8 +134,6 @@ in
     services.mingetty.helpLine = mkIf cfg.showManual
       "\nPress <Alt-F${toString cfg.ttyNumber}> for the NixOS manual.";
 
-    services.nixosManual.browser = mkDefault "${pkgs.w3m-nox}/bin/w3m";
-
   };
 
 }