about summary refs log tree commit diff
path: root/nixos/modules/services/misc/nixos-manual.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-05-05 15:18:53 -0400
committerNicolas B. Pierron <nicolas.b.pierron@gmail.com>2015-03-12 23:42:57 +0100
commit1d62ad474694c0717017c2c8aa79909a890407b5 (patch)
treef541c744e6e3747155bb2b5bd25491d634cc6abd /nixos/modules/services/misc/nixos-manual.nix
parent4f5c6330c9f3df2533daf33ecaf0c52420979674 (diff)
downloadnixlib-1d62ad474694c0717017c2c8aa79909a890407b5.tar
nixlib-1d62ad474694c0717017c2c8aa79909a890407b5.tar.gz
nixlib-1d62ad474694c0717017c2c8aa79909a890407b5.tar.bz2
nixlib-1d62ad474694c0717017c2c8aa79909a890407b5.tar.lz
nixlib-1d62ad474694c0717017c2c8aa79909a890407b5.tar.xz
nixlib-1d62ad474694c0717017c2c8aa79909a890407b5.tar.zst
nixlib-1d62ad474694c0717017c2c8aa79909a890407b5.zip
modules.nix: Generate the extra argument set from the configuration
This allows for module arguments to be handled modularly, in particular
allowing the nixpkgs module to handle the nixpkgs import internally.
This creates the __internal option namespace, which should only be added
to by the module system itself.
Diffstat (limited to 'nixos/modules/services/misc/nixos-manual.nix')
-rw-r--r--nixos/modules/services/misc/nixos-manual.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/misc/nixos-manual.nix b/nixos/modules/services/misc/nixos-manual.nix
index c0d7885280a5..72923f2b56a0 100644
--- a/nixos/modules/services/misc/nixos-manual.nix
+++ b/nixos/modules/services/misc/nixos-manual.nix
@@ -3,7 +3,7 @@
 # of the virtual consoles.  The latter is useful for the installation
 # CD.
 
-{ config, lib, pkgs, baseModules, ... } @ extraArgs:
+{ config, lib, pkgs, baseModules, ... }:
 
 with lib;
 
@@ -18,7 +18,7 @@ let
 
   eval = evalModules {
     modules = [ versionModule ] ++ baseModules;
-    args = (removeAttrs extraArgs ["config" "options"]) // { modules = [ ]; };
+    args = (config.__internal.args) // { modules = [ ]; };
   };
 
   manual = import ../../../doc/manual {