about summary refs log tree commit diff
path: root/nixos/modules/services/misc/mediatomb.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2019-09-01 03:07:23 +0200
committerFlorian Klink <flokli@flokli.de>2019-09-01 19:06:38 +0200
commitf74735c9d7e7b978827ff17b5f8cb375753dca0b (patch)
tree75809b54a017e6ac94cf507f14cf83387299b877 /nixos/modules/services/misc/mediatomb.nix
parent7f42adf7a2a6ab0f18dd441820f1089a7b2c0cfd (diff)
downloadnixlib-f74735c9d7e7b978827ff17b5f8cb375753dca0b.tar
nixlib-f74735c9d7e7b978827ff17b5f8cb375753dca0b.tar.gz
nixlib-f74735c9d7e7b978827ff17b5f8cb375753dca0b.tar.bz2
nixlib-f74735c9d7e7b978827ff17b5f8cb375753dca0b.tar.lz
nixlib-f74735c9d7e7b978827ff17b5f8cb375753dca0b.tar.xz
nixlib-f74735c9d7e7b978827ff17b5f8cb375753dca0b.tar.zst
nixlib-f74735c9d7e7b978827ff17b5f8cb375753dca0b.zip
nixos: remove dependencies on local-fs.target
Since https://github.com/NixOS/nixpkgs/pull/61321, local-fs.target is
part of sysinit.target again, meaning units without
DefaultDependencies=no will automatically depend on it, and the manual
set dependencies can be dropped.
Diffstat (limited to 'nixos/modules/services/misc/mediatomb.nix')
-rw-r--r--nixos/modules/services/misc/mediatomb.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/misc/mediatomb.nix b/nixos/modules/services/misc/mediatomb.nix
index dbf12fd1da39..107fb57fe1c4 100644
--- a/nixos/modules/services/misc/mediatomb.nix
+++ b/nixos/modules/services/misc/mediatomb.nix
@@ -259,7 +259,7 @@ in {
   config = mkIf cfg.enable {
     systemd.services.mediatomb = {
       description = "MediaTomb media Server";
-      after = [ "local-fs.target" "network.target" ];
+      after = [ "network.target" ];
       wantedBy = [ "multi-user.target" ];
       path = [ pkgs.mediatomb ];
       serviceConfig.ExecStart = "${pkgs.mediatomb}/bin/mediatomb -p ${toString cfg.port} ${if cfg.interface!="" then "-e ${cfg.interface}" else ""} ${if cfg.customCfg then "" else "-c ${mtConf}"} -m ${cfg.dataDir}";