about summary refs log tree commit diff
path: root/nixos/modules/services/misc/guix/default.nix
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2023-12-08 18:00:53 +0000
committerGitHub <noreply@github.com>2023-12-08 18:00:53 +0000
commit5f3708016ca0ef547d3fb79a521e9d5bad15d454 (patch)
treec2e70dd0d246f0a5f493757b0b5fd79f181705ea /nixos/modules/services/misc/guix/default.nix
parent367355c96657f81fcedc3cd86d4657b29fab089e (diff)
parent869d88db9b1aee20665260a4964f558bec91018a (diff)
downloadnixlib-5f3708016ca0ef547d3fb79a521e9d5bad15d454.tar
nixlib-5f3708016ca0ef547d3fb79a521e9d5bad15d454.tar.gz
nixlib-5f3708016ca0ef547d3fb79a521e9d5bad15d454.tar.bz2
nixlib-5f3708016ca0ef547d3fb79a521e9d5bad15d454.tar.lz
nixlib-5f3708016ca0ef547d3fb79a521e9d5bad15d454.tar.xz
nixlib-5f3708016ca0ef547d3fb79a521e9d5bad15d454.tar.zst
nixlib-5f3708016ca0ef547d3fb79a521e9d5bad15d454.zip
Merge master into staging-next
Diffstat (limited to 'nixos/modules/services/misc/guix/default.nix')
-rw-r--r--nixos/modules/services/misc/guix/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/misc/guix/default.nix b/nixos/modules/services/misc/guix/default.nix
index 00e84dc74554..7b468e7067cc 100644
--- a/nixos/modules/services/misc/guix/default.nix
+++ b/nixos/modules/services/misc/guix/default.nix
@@ -265,7 +265,7 @@ in
         linkProfileToPath = acc: profile: location: let
           guixProfile = "${cfg.stateDir}/guix/profiles/per-user/\${USER}/${profile}";
           in acc + ''
-            [ -d "${guixProfile}" ] && ln -sf "${guixProfile}" "${location}"
+            [ -d "${guixProfile}" ] && [ -L "${location}" ] || ln -sf "${guixProfile}" "${location}"
           '';
 
         activationScript = lib.foldlAttrs linkProfileToPath "" guixUserProfiles;